summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-06 16:41:45 +0200
committerMarius Bakke <marius@gnu.org>2021-05-06 19:10:05 +0200
commit243552674eee9cacc5ced03c7c9e67cb78560a79 (patch)
treee8c19852d752272e95fdccab380b45ed43e0a67d
parent10213079f49ef42cd7b6d18c622065567d74463f (diff)
downloadguix-patches-243552674eee9cacc5ced03c7c9e67cb78560a79.tar
guix-patches-243552674eee9cacc5ced03c7c9e67cb78560a79.tar.gz
gnu: python-hacking: Fix build failure.
This follows up on 9095fccd0ea7789d5b87e5d1948d875d2029f7da, et.al. * gnu/packages/python-xyz.scm (python-pycodestyle-2.6, python-pyflakes-2.2, python-flake8-3.8): New variables. * gnu/packages/openstack.scm (python-hacking)[propagated-inputs]: Change from PYTHON-FLAKE8 to PYTHON-FLAKE8-3.8.
-rw-r--r--gnu/packages/openstack.scm2
-rw-r--r--gnu/packages/python-xyz.scm38
2 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 1e3ad1057a..99e17d8e43 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -150,7 +150,7 @@ manner.")
"062rvbkvbavqqz55f7q00ikwipkn5j0rdls1rrajdbfwgckjcrsm"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-flake8" ,python-flake8)))
+ `(("python-flake8" ,python-flake8-3.8)))
(native-inputs
`( ;; Tests
("python-coverage" ,python-coverage)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 78dcaa5db8..3a01b74d1d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5842,6 +5842,17 @@ Python code against some of the style conventions in
(define-public python2-pycodestyle
(package-with-python2 python-pycodestyle))
+(define-public python-pycodestyle-2.6
+ (package
+ (inherit python-pycodestyle)
+ (version "2.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycodestyle" version))
+ (sha256
+ (base32
+ "0bhr6ia0hmgx3nhgibc9pmkzhlh1zcqk707i5fbxgs702ll7v2n5"))))))
+
(define-public python-multidict
(package
(name "python-multidict")
@@ -8970,6 +8981,17 @@ PEP 8.")
(define-public python2-pyflakes
(package-with-python2 python-pyflakes))
+(define-public python-pyflakes-2.2
+ (package
+ (inherit python-pyflakes)
+ (version "2.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyflakes" version))
+ (sha256
+ (base32
+ "1j3zqbiwkyicvww499bblq33x0bjpzdrxajhaysr7sk7x5gdgcim"))))))
+
(define-public python-mccabe
(package
(name "python-mccabe")
@@ -9039,6 +9061,22 @@ complexity of Python source code.")
("python2-typing" ,python2-typing)
,@(package-propagated-inputs base))))))
+(define-public python-flake8-3.8
+ (package
+ (inherit python-flake8)
+ (version "3.8.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "0fvcrsbyzjpcli8ldbpsdbpmf238nkvwc1dy4hy82lf63rvfinma"))))
+ (propagated-inputs
+ `(("python-pycodestyle" ,python-pycodestyle-2.6)
+ ("python-entrypoints" ,python-entrypoints)
+ ("python-pyflakes" ,python-pyflakes-2.2)
+ ("python-mccabe" ,python-mccabe)))))
+
(define-public python-flake8-bugbear
(package
(name "python-flake8-bugbear")