summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-03-16 13:11:09 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-16 16:44:23 +0300
commit22d628148ce857b620f5b8e48dc7cabe004313c5 (patch)
tree9f755673ae634f3cbcfb1962d0605ad6bb32fcf4
parent46264c73a6364e0510cbe6841a135da5d7f29dfa (diff)
downloadguix-patches-22d628148ce857b620f5b8e48dc7cabe004313c5.tar
guix-patches-22d628148ce857b620f5b8e48dc7cabe004313c5.tar.gz
gnu: Add emacs-exec-path-from-shell.
* gnu/packages/emacs.scm (emacs-exec-path-from-shell): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c2c162c75c..fbdde863c7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7361,3 +7361,28 @@ highlighting and indentation support.")
@uref{https://www.terraform.io/, Terraform} configuration files. Most of the
functionality is inherited from @code{hcl-mode}.")
(license license:gpl3+)))
+
+(define-public emacs-exec-path-from-shell
+ (package
+ (name "emacs-exec-path-from-shell")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://stable.melpa.org/packages/exec-path-from-shell-"
+ version ".el"))
+ (sha256
+ (base32
+ "03qjgb81cq1l3j54lvlf98r75vmmgd06mj6qh5wa6mz4xzp4w26r"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/exec-path-from-shell")
+ (synopsis "Get environment variables such as @var{PATH} from the shell")
+ (description
+ "This library allows the user to set Emacs @var{exec-path} and @var{PATH}
+from the shell @var{PATH}, so that @code{shell-command}, @code{compile} and
+the like work as expected on systems on which Emacs is not guaranteed to
+inherit a login shell's environment variables. It also allows other
+environment variables to be retrieved from the shell, so that Emacs will see
+the same values you get in a terminal.")
+ (license license:gpl3+)))