summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:57:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:58:19 +0200
commit2279e3e60479e91838db2d7261e86e91f9891650 (patch)
treeed94a16f7ae85eccd0fd7c14c79a29a7c343e08f
parent2c7b25402e35796d49e51ceaa2ac8ba92b0cbc77 (diff)
downloadguix-patches-2279e3e60479e91838db2d7261e86e91f9891650.tar
guix-patches-2279e3e60479e91838db2d7261e86e91f9891650.tar.gz
gnu: Add texlive-scheme-tetex.
* gnu/packages/tex.scm (texlive-scheme-tetex): New variable.
-rw-r--r--gnu/packages/tex.scm75
1 files changed, 75 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56fe758524..7a0a3a8606 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1053,6 +1053,81 @@ variant. It adds XeTeX, MetaPost, and some recommended packages to
@code{scheme-basic}.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-scheme-tetex
+ (package
+ (name "texlive-scheme-tetex")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-acronym
+ texlive-amslatex-primer
+ texlive-bbm
+ texlive-bbm-macros
+ texlive-bbold
+ texlive-bibtex8
+ texlive-cmbright
+ texlive-collection-basic
+ texlive-collection-context
+ texlive-collection-fontsrecommended
+ texlive-collection-fontutils
+ texlive-collection-formatsextra
+ texlive-collection-langcjk
+ texlive-collection-langcyrillic
+ texlive-collection-langczechslovak
+ texlive-collection-langenglish
+ texlive-collection-langeuropean
+ texlive-collection-langfrench
+ texlive-collection-langgerman
+ texlive-collection-langgreek
+ texlive-collection-langitalian
+ texlive-collection-langother
+ texlive-collection-langpolish
+ texlive-collection-langportuguese
+ texlive-collection-langspanish
+ texlive-collection-latex
+ texlive-collection-latexrecommended
+ texlive-collection-mathscience
+ texlive-collection-metapost
+ texlive-collection-pictures
+ texlive-collection-plaingeneric
+ texlive-collection-pstricks
+ texlive-ctie
+ texlive-cweb
+ texlive-detex
+ texlive-dtl
+ texlive-dvi2tty
+ texlive-dvicopy
+ texlive-dvidvi
+ texlive-dviljk
+ texlive-eplain
+ texlive-eulervm
+ texlive-gentle
+ texlive-lshort-english
+ texlive-mltex
+ texlive-multirow
+ texlive-nomencl
+ texlive-patgen
+ texlive-pst-pdf
+ texlive-rsfs
+ texlive-seetexk
+ texlive-siunits
+ texlive-subfigure
+ texlive-supertabular
+ texlive-tamethebeast
+ texlive-tds
+ texlive-tex-refs
+ texlive-tie
+ texlive-web
+ texlive-xpdfopen))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "teTeX scheme (more than medium, but nowhere near full)")
+ (description
+ "Larger than medium, this TeX Live scheme is nearly equivalent to the
+teTeX distribution that was maintained by Thomas Esser.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
;; This package must be located before any package adding it to its native
;; inputs.
(define-public texlive-updmap.cfg