summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-14 14:44:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-14 14:50:59 +0200
commit222040095727d1ebb23a7f3755c7908c52eff381 (patch)
tree0d96a11979ec155854d1244ec375c7d90506ff1d
parent9c814c337946f5e70b0dbe45fb54f451b06fe0b2 (diff)
downloadguix-patches-222040095727d1ebb23a7f3755c7908c52eff381.tar
guix-patches-222040095727d1ebb23a7f3755c7908c52eff381.tar.gz
gnu: Add r-rcppziggurat.
* gnu/packages/cran.scm (r-rcppziggurat): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 11dba4e047..5b94d7572e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22925,3 +22925,32 @@ Compared to other approaches @code{cpp11} strives to be safe against long
jumps from the C API as well as C++ exceptions, conform to normal R function
semantics and supports interaction with @code{ALTREP} vectors.")
(license license:expat)))
+
+(define-public r-rcppziggurat
+ (package
+ (name "r-rcppziggurat")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RcppZiggurat" version))
+ (sha256
+ (base32
+ "0zmr3nvm5j0fpwxk3x9kxpwqbr66ldfvd10zy8xlgjbslz9myvfv"))))
+ (properties `((upstream-name . "RcppZiggurat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcppgsl" ,r-rcppgsl)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/RcppZiggurat/")
+ (synopsis "Rcpp integration of different \"Ziggurat\" normal RNG implementations")
+ (description
+ "The Ziggurat generator for normally distributed random numbers,
+originally proposed by Marsaglia and Tsang (2000,
+@url{https://doi.org/10.18637/jss.v005.i08}) has been improved upon a few
+times starting with Leong et al (2005,
+@url{https://doi.org/10.18637/jss.v012.i07}). This package provides an
+aggregation for comparing different implementations in order to provide a
+'faster but good enough' alternative for use with R and C++ code.")
+ (license license:gpl2+)))