summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-13 09:25:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-13 09:25:13 +0200
commit21cd4c704e3c75e89b5760157d61060787dcb71f (patch)
tree197c249a12ea9f0c0ddd632aa6b228cc96562a51
parent7bd5394bf8564920a4e647563dc8c0092858f8dd (diff)
downloadguix-patches-21cd4c704e3c75e89b5760157d61060787dcb71f.tar
guix-patches-21cd4c704e3c75e89b5760157d61060787dcb71f.tar.gz
gnu: awscli: Use PyYAML 6.
This should be fine because all uses of yaml.load supply the now mandatory loader argument. * gnu/packages/python-web.scm (awscli)[arguments]: Add phase 'use-recent-pyyaml. [propagated-inputs]: Replace python-pyyaml-for-awscli with python-pyyaml.
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ab6b11c3c6..da83646f95 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2880,6 +2880,12 @@ supports url redirection and retries, and also gzip and deflate decoding.")
'(#:tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'use-recent-pyyaml
+ (lambda _
+ (substitute* '("awscli.egg-info/requires.txt"
+ "setup.cfg"
+ "setup.py")
+ (("<5.5") "<=6"))))
(add-after 'unpack 'fix-reference-to-groff
(lambda _
(substitute* "awscli/help.py"
@@ -2892,7 +2898,7 @@ supports url redirection and retries, and also gzip and deflate decoding.")
python-botocore-for-awscli
python-s3transfer
python-docutils-0.15
- python-pyyaml-for-awscli
+ python-pyyaml
python-rsa))
(native-inputs
(list groff))