summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:41 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:49 +0200
commit2137cc44ba5321e21dfb0dde60612bf5cde3a4df (patch)
tree7004621768dea6fb5cec7720b69c44aecdb47384
parent570a4c77f892c4f625c0c638084a0549cb17bc58 (diff)
downloadguix-patches-2137cc44ba5321e21dfb0dde60612bf5cde3a4df.tar
guix-patches-2137cc44ba5321e21dfb0dde60612bf5cde3a4df.tar.gz
gnu: Add python-entrypoint2.
* gnu/packages/python-xyz.scm (python-entrypoint2): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dce50d6649..f4b3a60d25 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15197,6 +15197,31 @@ etc.")
"@code{easyprocess} is an easy to use Python subprocess interface.")
(license license:bsd-3)))
+(define-public python-entrypoint2
+ (package
+ (name "python-entrypoint2")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "entrypoint2" version))
+ (sha256
+ (base32 "1qyxq54r2fbh09ab5sffbxajy8arbk6czxz5lq3ccr9qrypw6w27"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"))
+ (native-inputs
+ `(("python-easyprocess" ,python-easyprocess)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/ponty/entrypoint2")
+ (synopsis "Command-line interface for Python modules")
+ (description
+ "@code{entrypoint2} is an easy to use command-line interface for Python
+modules based on @code{argparse}. It translates function signature and
+documentation to argparse configuration.")
+ (license license:bsd-3)))
+
(define-public python-stem
(package
(name "python-stem")