summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-01 21:41:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-10 11:41:43 +0300
commit213238d943c477a7e2a6e705b662ddec6556cc0a (patch)
treecd3b588e4842455ebaf2e1f62ee8b9172be0e49c
parentf47d2793665a0e01d93a7a9cff7f9c7402d838fb (diff)
downloadguix-patches-213238d943c477a7e2a6e705b662ddec6556cc0a.tar
guix-patches-213238d943c477a7e2a6e705b662ddec6556cc0a.tar.gz
gnu: Add qtremoteobjects.
* gnu/packages/qt.scm (qtremoteobjects): New variable.
-rw-r--r--gnu/packages/qt.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index dfe99a25bd..5067054731 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1197,6 +1197,23 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(inputs
`(("qtbase" ,qtbase)))))
+(define-public qtremoteobjects
+ (package (inherit qtsvg)
+ (name "qtremoteobjects")
+ (version "5.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.qt.io/official_releases/qt/"
+ (version-major+minor version) "/" version
+ "/submodules/" name "-opensource-src-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "10kwq0fgmi6zsqhb6s1nkcydpyl8d8flzdpgmyj50c4h2xhg2km0"))))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))))
+
(define-public python-sip
(package
(name "python-sip")