summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-07 22:45:00 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-07 23:32:01 +0100
commit202440e07a9dd40dc4b9814a91c67e24554d53c1 (patch)
tree1035d4a2fd388299b9acb2e349442077b2ac8a1d
parentfa04a04f18bbab671459ea789fb61da6cd1d74fb (diff)
downloadguix-patches-202440e07a9dd40dc4b9814a91c67e24554d53c1.tar
guix-patches-202440e07a9dd40dc4b9814a91c67e24554d53c1.tar.gz
gnu-maintenance: Add tests for 'release-file?'.
* tests/gnu-maintenance.scm: New file. * Makefile.am (SCM_TESTS): Add it. * guix/gnu-maintenance.scm (release-file?): Export.
-rw-r--r--Makefile.am1
-rw-r--r--guix/gnu-maintenance.scm1
-rw-r--r--tests/gnu-maintenance.scm44
3 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 245070b033..4adf39ee05 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -199,6 +199,7 @@ SCM_TESTS = \
tests/pk-crypto.scm \
tests/pki.scm \
tests/sets.scm \
+ tests/gnu-maintenance.scm \
tests/substitute.scm \
tests/builders.scm \
tests/derivations.scm \
diff --git a/guix/gnu-maintenance.scm b/guix/gnu-maintenance.scm
index aa3202fd2c..b3240f82a4 100644
--- a/guix/gnu-maintenance.scm
+++ b/guix/gnu-maintenance.scm
@@ -50,6 +50,7 @@
find-packages
gnu-package?
+ release-file?
releases
latest-release
gnu-release-archive-types
diff --git a/tests/gnu-maintenance.scm b/tests/gnu-maintenance.scm
new file mode 100644
index 0000000000..e7296137dc
--- /dev/null
+++ b/tests/gnu-maintenance.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-gnu-maintenance)
+ #:use-module (guix gnu-maintenance)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64))
+
+(test-begin "gnu-maintenance")
+
+(test-assert "release-file?"
+ (and (every (lambda (project+file)
+ (apply release-file? project+file))
+ '(("gcc" "gcc-5.3.0.tar.bz2")
+ ("texmacs" "TeXmacs-1.0.7.9-src.tar.gz")
+ ("icecat" "icecat-38.4.0-gnu1.tar.bz2")
+ ("mit-scheme" "mit-scheme-9.2.tar.gz")))
+ (every (lambda (project+file)
+ (not (apply release-file? project+file)))
+ '(("guile" "guile-www-1.1.1.tar.gz")
+ ("guile" "guile-2.0.11.tar.gz.sig")
+ ("mit-scheme" "mit-scheme-9.2-i386.tar.gz")
+ ("mit-scheme" "mit-scheme-9.2-doc-pdf.tar.gz")
+ ("gnutls" "gnutls-3.2.18-w32.zip")))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))