summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-07-18 11:37:06 +0300
committerRicardo Wurmus <rekado@elephly.net>2017-07-22 12:26:29 +0200
commit1f84ff51352b99ccf5b98cf16798a03c938465fa (patch)
treeeab6376d2edc6854649309f09d214b79361b5095
parent3fee00395031a7144b108c2839fcbb570d5df8bd (diff)
downloadguix-patches-1f84ff51352b99ccf5b98cf16798a03c938465fa.tar
guix-patches-1f84ff51352b99ccf5b98cf16798a03c938465fa.tar.gz
gnu: Add python-clyent.
* gnu/packages/python.scm (python-clyent, python2-clyent): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index da139c2473..82be9e8542 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -676,6 +676,29 @@ saving time. Almost all of the Olson timezones are supported.")
(define-public python2-pytz
(package-with-python2 python-pytz))
+(define-public python-clyent
+ (package
+ (name "python-clyent")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "clyent" version))
+ (sha256
+ (base32
+ "1r9987qmy1pz3hq54160bapqsywpq14waw4w9x3ly8hmq7kpgfbj"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)))
+ (home-page "https://github.com/binstar/clyent")
+ (synopsis "Command line client library")
+ (description "Clyent is a Python command line utiliy library. It is used
+by @code{binstar}, @code{binstar-build} and @code{chalmers}.")
+ (license license:bsd-3)))
+
+(define-public python2-clyent
+ (package-with-python2 python-clyent))
+
(define-public python-babel
(package
(name "python-babel")