summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-07 13:50:14 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-08 13:43:17 +0200
commit17e0f8255cd26cfe41847c20cf213ccaea5144b1 (patch)
treef11227a27535e65c344e600ff7073b3fe1bbdda0
parent440217b1e5e8f7c4570e23494f932ff620eedee2 (diff)
downloadguix-patches-17e0f8255cd26cfe41847c20cf213ccaea5144b1.tar
guix-patches-17e0f8255cd26cfe41847c20cf213ccaea5144b1.tar.gz
gnu: sbcl-numcl: Disable tests.
* gnu/packages/lisp-xyz.scm (sbcl-numcl)[arguments]: Disable tests.
-rw-r--r--gnu/packages/lisp-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 55aab91115..9e2b96009d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10006,7 +10006,10 @@ type correctness in Common Lisp. It is based on CLtL2 extensions.")
(build-system asdf-build-system/sbcl)
(arguments
`(#:test-asd-file "numcl.test.asd"
- #:asd-files '("numcl.asd")))
+ #:asd-files '("numcl.asd")
+ ;; Tests often fail because they require a dynamic-space-size much
+ ;; bigger than the default one. Disable them for now.
+ #:tests? #f))
(native-inputs
`(("fiveam" ,sbcl-fiveam)))
(inputs