summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:24:52 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:50 +0200
commit177f38c7fee90bb4a5b35ec66fa70791f5a92cc2 (patch)
tree5193cd66250c02030ad1c829f222a80da9dae3cc
parent3587effb7a737c4c64796d8ae1b6f73166c36149 (diff)
downloadguix-patches-177f38c7fee90bb4a5b35ec66fa70791f5a92cc2.tar
guix-patches-177f38c7fee90bb4a5b35ec66fa70791f5a92cc2.tar.gz
gnu: Add r-digest.
* gnu/packages/statistics.scm (r-digest): New variable.
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0eddbaf7f9..662bb46191 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -160,3 +160,29 @@ colors are provided.")
"Dichromat collapses red-green or green-blue distinctions to simulate the
effects of different types of color-blindness.")
(license license:gpl2+)))
+
+(define-public r-digest
+ (package
+ (name "r-digest")
+ (version "0.6.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/digest_"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0m9grqv67hhf51lz10whymhw0g0d98466ka694kya5x95hn44qih"))))
+ (build-system r-build-system)
+ (home-page "http://dirk.eddelbuettel.com/code/digest.html")
+ (synopsis "Create cryptographic hash digests of R objects")
+ (description
+ "This package contains an implementation of a function 'digest()' for the
+creation of hash digests of arbitrary R objects (using the md5, sha-1,
+sha-256, crc32, xxhash and murmurhash algorithms) permitting easy comparison
+of R language objects, as well as a function 'hmac()' to create hash-based
+message authentication code.
+
+Please note that this package is not meant to be deployed for cryptographic
+purposes for which more comprehensive (and widely tested) libraries such as
+OpenSSL should be used.")
+ (license license:gpl2+)))