summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-24 20:30:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-29 01:05:26 -0400
commit165cbdfdc11a4826b64b42bd15af64b9e5930de4 (patch)
tree9ee7a6ab187721add9136dc42ae8a93328f364be
parentafcbaadac5d6add0bb493471220d81d4acb630e5 (diff)
downloadguix-patches-165cbdfdc11a4826b64b42bd15af64b9e5930de4.tar
guix-patches-165cbdfdc11a4826b64b42bd15af64b9e5930de4.tar.gz
gnu: Add python-resolvelib-0.5.
* gnu/packages/python-xyz.scm (python-resolvelib-0.5): New variable.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83db31a737..da27b1755d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10222,6 +10222,22 @@ similar to the Python standard library's @code{json} module.")
includes dependency resolution logic.")
(license license:isc)))
+;;; This older version is required by ansible-core.
+(define-public python-resolvelib-0.5
+ (package/inherit python-resolvelib
+ (name "python-resolvelib")
+ (version "0.5.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sarugaku/resolvelib")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0697y330sqhiclk25v151qxg7aixzpj434lbg5qib0qlna5zg9la"))))))
+
(define-public python-commonmark
(package
(name "python-commonmark")