summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-30 08:57:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-30 09:28:26 +0300
commit1628d57bb5c6ab30a04202c229de642b94faac85 (patch)
treeb0232c76db0b58dd4f91a30ff636369e89ece0ff
parent1537587e4653f0931e001cbc81a91fb68c38677f (diff)
downloadguix-patches-1628d57bb5c6ab30a04202c229de642b94faac85.tar
guix-patches-1628d57bb5c6ab30a04202c229de642b94faac85.tar.gz
gnu: Fix package references.
* gnu/packages/algebra.scm (iml)[inputs]: Correctly refer to package inputs. * gnu/packages/astronomy.scm (xplanet), * gnu/packages/audio.scm (redkite, libaudec, lv2lint, lv2toweb), * gnu/packages/bioconductor.scm (r-cummerbund), * gnu/packages/chicken.scm (chicken), * gnu/packages/conky.scm (conky), * gnu/packages/cran.scm (r-latex2exp), * gnu/packages/crates-io.scm (rust-rgb), * gnu/packages/databases.scm (mariadb), * gnu/packages/diffoscope.scm (reprotest), * gnu/packages/file-systems.scm (glusterfs), * gnu/packages/finance.scm (electron-cash), * gnu/packages/games.scm (rinutils, ksudoku, kdiamond, kigo), * gnu/packages/geo.scm (grass), * gnu/packages/gnome.scm (libmediaart, gnome-contacts, geoclue), * gnu/packages/gnucash.scm (aqbanking), * gnu/packages/image.scm (mtpaint), * gnu/packages/kde-internet.scm (kopete, ktorrent), * gnu/packages/kde-utils.scm (kmousetool, kmouth, kronometer), * gnu/packages/linphone.scm (liblinphone), * gnu/packages/maths.scm (ppl), * gnu/packages/mercury.scm (mercury-minimal), * gnu/packages/music.scm (bjumblr, bschaffl, lsp-plugins, spectacle-analyzer, helm, tap-lv2, wolf-shaper, shiru-lv2), * gnu/packages/networking.scm (restinio), * gnu/packages/prolog.scm (swi-prolog), * gnu/packages/python-web.scm (gunicorn), * gnu/packages/python-xyz.scm (python-docusign-esign), * gnu/packages/ruby.scm (ruby-cucumber, ruby_version, ruby-addressable), * gnu/packages/sagemath.scm (python-cypari2), * gnu/packages/skarnet.scm (s6-linux-init), * gnu/packages/vpn.scm (sshuttle), * gnu/packages/web.scm (libcyaml), * gnu/packages/xdisorg.scm (kbdd), * gnu/packages/xorg.scm (xpra): Same.
-rw-r--r--gnu/packages/algebra.scm2
-rw-r--r--gnu/packages/astronomy.scm2
-rw-r--r--gnu/packages/audio.scm20
-rw-r--r--gnu/packages/bioconductor.scm2
-rw-r--r--gnu/packages/chicken.scm2
-rw-r--r--gnu/packages/conky.scm2
-rw-r--r--gnu/packages/cran.scm2
-rw-r--r--gnu/packages/crates-io.scm2
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/diffoscope.scm2
-rw-r--r--gnu/packages/file-systems.scm10
-rw-r--r--gnu/packages/finance.scm4
-rw-r--r--gnu/packages/games.scm8
-rw-r--r--gnu/packages/geo.scm2
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/gnucash.scm2
-rw-r--r--gnu/packages/image.scm6
-rw-r--r--gnu/packages/kde-internet.scm4
-rw-r--r--gnu/packages/kde-utils.scm8
-rw-r--r--gnu/packages/linphone.scm2
-rw-r--r--gnu/packages/maths.scm4
-rw-r--r--gnu/packages/mercury.scm2
-rw-r--r--gnu/packages/music.scm68
-rw-r--r--gnu/packages/networking.scm4
-rw-r--r--gnu/packages/prolog.scm2
-rw-r--r--gnu/packages/python-web.scm2
-rw-r--r--gnu/packages/python-xyz.scm14
-rw-r--r--gnu/packages/ruby.scm6
-rw-r--r--gnu/packages/sagemath.scm2
-rw-r--r--gnu/packages/skarnet.scm2
-rw-r--r--gnu/packages/vpn.scm2
-rw-r--r--gnu/packages/web.scm2
-rw-r--r--gnu/packages/xdisorg.scm2
-rw-r--r--gnu/packages/xorg.scm2
34 files changed, 102 insertions, 102 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 262a7939df..912ec2fe64 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1553,7 +1553,7 @@ structure constants of Schubert polynomials.")
"0akwhhz9b40bz6lrfxpamp7r7wkk48p455qbn04mfnl9a1l6db8x"))))
(build-system gnu-build-system)
(inputs
- `(("gmp", gmp)
+ `(("gmp" ,gmp)
("cblas" ,openblas))) ; or any other BLAS library; the documentation
; mentions ATLAS in particular
(arguments
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 785d281887..353ba96a32 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -328,7 +328,7 @@ Mechanics, Astrometry and Astrodynamics library.")
("freetype" ,freetype)
("pango" ,pango)
("giflib" ,giflib)
- ("libjpeg", libjpeg-turbo)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
("netpbm" ,netpbm)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a50266965b..0e93a7263e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4519,7 +4519,7 @@ workstations as well as consumer software such as music players.")
(inputs
`(("cairo" ,cairo)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "Small GUI toolkit")
(description "Redkite is a small GUI toolkit developed in C++17 and
inspired from other well known GUI toolkits such as Qt and GTK. It is
@@ -4665,7 +4665,7 @@ in the package.")
`(("libsamplerate" ,libsamplerate)
("libsndfile" ,libsndfile)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "Library for reading and resampling audio files")
(description "libaudec is a wrapper library over ffmpeg, sndfile and
libsamplerate for reading and resampling audio files, based on Robin Gareus'
@@ -4693,11 +4693,11 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
`("-Delf-tests=true" ; for checking symbol visibility
"-Donline-tests=true"))) ; for checking URI existence
(inputs
- `(("curl", curl)
- ("libelf", libelf)
- ("lilv", lilv)))
+ `(("curl" ,curl)
+ ("libelf" ,libelf)
+ ("lilv" ,lilv)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "LV2 plugin lint tool")
(description "lv2lint is an LV2 lint-like tool that checks whether a
given plugin and its UI(s) match up with the provided metadata and adhere
@@ -4728,11 +4728,11 @@ to well-known best practices.")
(modify-phases %standard-phases
(delete 'configure))))
(inputs
- `(("jalv", jalv)
- ("lilv", lilv)))
+ `(("jalv" ,jalv)
+ ("lilv" ,lilv)))
(native-inputs
- `(("help2man", help2man)
- ("pkg-config", pkg-config)))
+ `(("help2man" ,help2man)
+ ("pkg-config" ,pkg-config)))
(synopsis "Documentation generator for LV2 plugins")
(description
"lv2toweb allows the user to create an xhtml page with information
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7eef0485be..4ca0906fbf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1115,7 +1115,7 @@ how the coverage distributed across the genome.")
(propagated-inputs
`(("r-biobase" ,r-biobase)
("r-biocgenerics" ,r-biocgenerics)
- ("r-fastcluster", r-fastcluster)
+ ("r-fastcluster" ,r-fastcluster)
("r-ggplot2" ,r-ggplot2)
("r-gviz" ,r-gviz)
("r-plyr" ,r-plyr)
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 7b86a58012..729cf25a6c 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -59,7 +59,7 @@
;; Parallel builds are not supported, as noted in README.
#:parallel-build? #f))
- (propagated-inputs `(("gcc-toolchain", gcc-toolchain)))
+ (propagated-inputs `(("gcc-toolchain" ,gcc-toolchain)))
(home-page "https://www.call-cc.org/")
(synopsis "R5RS Scheme implementation that compiles native code via C")
(description
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 6bae336b1c..0df6d1f760 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -79,7 +79,7 @@
("libxext" ,libxext)
("libxft" ,libxft)
("libxinerama" ,libxinerama)
- ("pulseaudio", pulseaudio)
+ ("pulseaudio" ,pulseaudio)
("lua" ,lua)
("ncurses" ,ncurses)
("curl" ,curl)))
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 50ce111123..0939c4d5a6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21899,7 +21899,7 @@ appropriate dog and cat images for many status codes.")
(build-system r-build-system)
(propagated-inputs
`(("r-stringr" ,r-stringr)
- ("r-magrittr", r-magrittr)))
+ ("r-magrittr" ,r-magrittr)))
(home-page "https://github.com/stefano-meschiari/latex2exp/")
(synopsis "Use LaTeX expressions in plots")
(description "@code{latex2exp} parses and converts LaTeX math formulas to
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5c31a66208..37e4e69d3f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21255,7 +21255,7 @@ uses finite automata and guarantees linear time matching on all inputs.")
(arguments
`(#:cargo-inputs
(("rust-bytemuck" ,rust-bytemuck-1)
- ("rust-serde", rust-serde-1))
+ ("rust-serde" ,rust-serde-1))
#:cargo-development-inputs
(("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://lib.rs/crates/rgb")
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c86297b293..a3eef034a6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -944,7 +944,7 @@ Language.")
`(("bison" ,bison)
;; XXX: On armhf, use GCC 5 to work around <https://bugs.gnu.org/37605>.
,@(if (string-prefix? "armhf" (%current-system))
- `(("gcc@5", gcc-5))
+ `(("gcc@5" ,gcc-5))
'())
("perl" ,perl)))
(inputs
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 9480f1f226..3e7ab7d7ba 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -254,7 +254,7 @@ install.")
(inputs
`(("python-debian" ,python-debian)
("python-distro" ,python-distro)
- ("python-libarchive-c", python-libarchive-c)
+ ("python-libarchive-c" ,python-libarchive-c)
("python-rstr" ,python-rstr)))
(native-inputs
`(("diffoscope" ,diffoscope)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 046deb67ab..0d897a6307 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -504,8 +504,8 @@ non-determinism in the build process.")
(lambda _ (invoke "./autogen.sh"))))))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("libtirpc", libtirpc)
- ("rpcsvc-proto", rpcsvc-proto)
+ ("libtirpc" ,libtirpc)
+ ("rpcsvc-proto" ,rpcsvc-proto)
("python-2" ,python-2) ; must be version 2
("flex" ,flex)
("bison" ,bison)
@@ -515,15 +515,15 @@ non-determinism in the build process.")
("cmocka" ,cmocka)))
(inputs
`(("acl" ,acl)
- ("fuse", fuse)
+ ("fuse" ,fuse)
("openssl" ,openssl)
("liburcu" ,liburcu)
("libuuid" ,util-linux "lib")
("libxml2" ,libxml2)
("readline" ,readline)
("zlib" ,zlib)
- ("libaio", libaio)
- ("rdma-core", rdma-core)))
+ ("libaio" ,libaio)
+ ("rdma-core" ,rdma-core)))
(home-page "https://www.gluster.org")
(synopsis "Distributed file system")
(description "GlusterFS is a distributed scalable network file system
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 863914bd35..05cb0ad88b 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -493,10 +493,10 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(build-system python-build-system)
(inputs
`(("libevent" ,libevent)
- ("libsecp256k1", libsecp256k1-bitcoin-cash)
+ ("libsecp256k1" ,libsecp256k1-bitcoin-cash)
("openssl" ,openssl)
("python-cython" ,python-cython)
- ("python-dateutil", python-dateutil)
+ ("python-dateutil" ,python-dateutil)
("python-dnspython" ,python-dnspython)
("python-ecdsa" ,python-ecdsa)
("python-hidapi" ,python-hidapi)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a90e708ab3..4423d51336 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7180,7 +7180,7 @@ original.")
("pkg-config" ,pkg-config)))
(inputs
`(("cmocka" ,cmocka)
- ("perl-env-path", perl-env-path)
+ ("perl-env-path" ,perl-env-path)
("perl-inline" ,perl-inline)
("perl-inline-c" ,perl-inline-c)
("perl-string-shellquote" ,perl-string-shellquote)
@@ -10176,7 +10176,7 @@ This package is part of the KDE games module.")
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)))
(inputs
- `(("karchive", karchive)
+ `(("karchive" ,karchive)
("kconfig" ,kconfig)
("kconfigwidgets" ,kconfigwidgets)
("kcoreaddons" ,kcoreaddons)
@@ -10322,7 +10322,7 @@ This package is part of the KDE games module.")
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)))
(inputs
- `(("kcompletion", kcompletion)
+ `(("kcompletion" ,kcompletion)
("kconfig" ,kconfig)
("kconfigwidgets" ,kconfigwidgets)
("kcoreaddons" ,kcoreaddons)
@@ -10714,7 +10714,7 @@ This package is part of the KDE games module.")
("kdbusaddons" ,kdbusaddons)
("ki18n" ,ki18n)
("kio" ,kio)
- ("knewstuff", knewstuff)
+ ("knewstuff" ,knewstuff)
("ktextwidgets" ,ktextwidgets)
("kxmlgui" ,kxmlgui)
("libkdegames" ,libkdegames)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 291b928338..0605d84c0e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1776,7 +1776,7 @@ track your position right from your laptop.")
(base32 "1fwsm99kz0bxvjk7442qq1h45ikrmhba8bqclafb61gqg1q6ymrk"))))
(build-system gnu-build-system)
(inputs
- `(("bzip2", bzip2)
+ `(("bzip2" ,bzip2)
("cairo" ,cairo)
("fftw" ,fftw)
("freetype" ,freetype)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 77ed6678cd..da4b2771e8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1299,7 +1299,7 @@ and implementation of UPnP A/V profiles.")
`(("gdk-pixbuf" ,gdk-pixbuf)
("gettext" ,gettext-minimal)
("gobject-introspection" ,gobject-introspection)
- ("gtk+:doc", gtk+ "doc")
+ ("gtk+:doc" ,gtk+ "doc")
("vala" ,vala)))
(synopsis "Media art library for the GNOME desktop")
(description
@@ -1961,7 +1961,7 @@ commonly used macros.")
("telepathy-glib" ,telepathy-glib)
("vala" ,vala)))
(propagated-inputs
- `(("folks", folks)
+ `(("folks" ,folks)
("telepathy-mission-control" ,telepathy-mission-control)))
(synopsis "GNOME's integrated address book")
(description
@@ -5025,7 +5025,7 @@ output devices.")
("gobject-introspection" ,gobject-introspection)
("modem-manager" ,modem-manager)
("libnotify" ,libnotify)
- ("gtk-doc", gtk-doc)
+ ("gtk-doc" ,gtk-doc)
("intltool" ,intltool)))
(inputs
`(("avahi" ,avahi)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 43aad3ed02..8f58ce332a 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -293,7 +293,7 @@ applications and libraries. It is used by AqBanking.")
("gnutls" ,gnutls)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("gettext-minimal", gettext-minimal)
+ ("gettext-minimal" ,gettext-minimal)
("libltdl" ,libltdl)))
(home-page "https://www.aquamaniac.de/sites/aqbanking/index.php")
(synopsis "Interface for online banking tasks")
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index bec03886a6..8fbdd0b4ae 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2180,12 +2180,12 @@ by AOM, including with alpha.")
`(("imlib2" ,imlib2)
("libtiff" ,libtiff)
("libpng" ,libpng)
- ("libungif", libungif)
- ("libjpeg", libjpeg-turbo)
+ ("libungif" ,libungif)
+ ("libjpeg" ,libjpeg-turbo)
("libwebp" ,libwebp)
("openjpeg" ,openjpeg)
("lcms" ,lcms)
- ("zlib", zlib)
+ ("zlib" ,zlib)
("glib" ,glib)
;; Support for gtk3 is in the testing stage.
("gtk+" ,gtk+-2)))
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index f9cd29e9b8..800554a36e 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -297,7 +297,7 @@ Features are:
("libxml2" ,libxml2)
("libxstl" ,libxslt)
;; TODO: Mediastreamer
- ("openssl", openssl)
+ ("openssl" ,openssl)
("ortp" ,ortp)
("phonon" ,phonon)
("qca" ,qca)
@@ -403,7 +403,7 @@ This package is part of the KDE networking module.")
("knotifyconfig" ,knotifyconfig)
("kparts" ,kparts)
("kplotting" ,kplotting)
- ("kross", kross)
+ ("kross" ,kross)
("kwidgetsaddons" ,kwidgetsaddons)
("kwindowsystem" ,kwindowsystem)
("kxmlgui" ,kxmlgui)
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 4d9f3736c8..00ef15b9d9 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -149,7 +149,7 @@ artists to web-designers to people with low vision.")
(inputs
`(("kauth" ,kauth)
("kcoreaddons" ,kcoreaddons)
- ("kconfigwidgets", kconfigwidgets)
+ ("kconfigwidgets" ,kconfigwidgets)
("kdbusaddons" ,kdbusaddons)
("ki18n" ,ki18n)
("kiconthemes" ,kiconthemes)
@@ -187,8 +187,8 @@ whom pressing buttons hurts.")
("kdoctools" ,kdoctools)))
(inputs
`(("kcompletion" ,kcompletion)
- ("kconfig", kconfig)
- ("kconfigwidgets", kconfigwidgets)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
("kcoreaddons" ,kcoreaddons)
("kcrash" ,kcrash)
("ki18n" ,ki18n)
@@ -228,7 +228,7 @@ sentences to be re-spoken.")
(inputs
`(("kauth" ,kauth)
("kconfig" ,kconfig)
- ("kconfigwidgets", kconfigwidgets)
+ ("kconfigwidgets" ,kconfigwidgets)
("kcoreaddons" ,kcoreaddons)
("kcrash" ,kcrash)
("ki18n" ,ki18n)
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index a6492893c8..777485b9ea 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -483,7 +483,7 @@ including media capture, encoding and decoding, and rendering.")
`(("bctoolbox" ,bctoolbox)
("belcard" ,belcard)
("bellesip" ,belle-sip)
- ("bzrtp", bzrtp)
+ ("bzrtp" ,bzrtp)
("iconv" ,libiconv)
("glib" ,glib)
("gtk2" ,gtk+-2)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ce393cba80..93ee2db60a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5764,10 +5764,10 @@ compiled against the nauty library.")
"1j5aji1g2vmdvc0gqz45n2ll2l2f6czca04wiyfl5g3sm3a6vhvb"))))
(build-system gnu-build-system)
(native-inputs
- `(("m4", m4)))
+ `(("m4" ,m4)))
(inputs
`(("glpk" ,glpk)
- ("gmp", gmp)))
+ ("gmp" ,gmp)))
(home-page "https://www.bugseng.com/parma-polyhedra-library")
(synopsis
"Parma Polyhedra Library for computations with polyhedra")
diff --git a/gnu/packages/mercury.scm b/gnu/packages/mercury.scm
index a6ae451e63..bab8909862 100644
--- a/gnu/packages/mercury.scm
+++ b/gnu/packages/mercury.scm
@@ -138,7 +138,7 @@
(native-inputs
`(("texinfo" ,texinfo)
("flex" ,flex)
- ("tcsh", tcsh)
+ ("tcsh" ,tcsh)
("bison" ,bison)
("readline" ,readline)
("libatomic-ops" ,(package-source
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 54c8e14669..1727bac7b8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1391,9 +1391,9 @@ B.Choppr is the successor of B.Slizr.")
(base32
"0kl6hrxmqrdf0195bfnzsa2h1073fgiqrfhg2276fm1954sm994v"))))
(inputs
- `(("cairo", cairo)
- ("libsndfile", libsndfile)
- ("lv2", lv2)))
+ `(("cairo" ,cairo)
+ ("libsndfile" ,libsndfile)
+ ("lv2" ,lv2)))
(synopsis "Pattern-controlled audio stream/sample re-sequencer LV2 plugin")
(description "B.Jumblr is a pattern-controlled audio stream / sample
re-sequencer LV2 plugin.")
@@ -1416,11 +1416,11 @@ re-sequencer LV2 plugin.")
(base32
"1c09acqrbd387ba41f8ch1qykdap5h6cg9if5pgd16i4dmjnpghj"))))
(inputs
- `(("cairo", cairo)
+ `(("cairo" ,cairo)
("fontconfig" ,fontconfig)
- ("libsndfile", libsndfile)
+ ("libsndfile" ,libsndfile)
("libx11" ,libx11)
- ("lv2", lv2)))
+ ("lv2" ,lv2)))
(home-page "https://github.com/sjaehn/BSchaffl")
(synopsis "Pattern-controlled MIDI amp & time stretch LV2 plugin")
(description "This package provides an LV2 plugin that allows for
@@ -5098,15 +5098,15 @@ and reverb.")
(delete 'configure)) ; no configure
#:test-target "test"))
(inputs
- `(("cairo", cairo)
- ("hicolor-icon-theme", hicolor-icon-theme)
- ("jack", jack-1)
- ("ladspa", ladspa)
- ("libsndfile", libsndfile)
- ("lv2", lv2)
- ("mesa", mesa)))
+ `(("cairo" ,cairo)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("jack" ,jack-1)
+ ("ladspa" ,ladspa)
+ ("libsndfile" ,libsndfile)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "Audio plugin collection")
(description "LSP (Linux Studio Plugins) is a collection of audio
plugins available as LADSPA/LV2 plugins and as standalone JACK
@@ -5216,12 +5216,12 @@ as a whole to realisticly reproduce the features and flaws of the real deal.")
`(("pkg-config" ,pkg-config)
("xxd" ,xxd)))
(inputs
- `(("cairo", cairo)
- ("fftw", fftw)
- ("fftwf", fftwf)
- ("jack", jack-1)
- ("lv2", lv2)
- ("mesa", mesa)))
+ `(("cairo" ,cairo)
+ ("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
(synopsis "Realtime graphical spectrum analyzer")
(description "Spectacle is a real-time spectral analyzer using the
short-time Fourier transform, available as LV2 audio plugin and JACK client.")
@@ -5515,12 +5515,12 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
("freetype2" ,freetype)
("hicolor-icon-theme" ,hicolor-icon-theme)
("libxcursor" ,libxcursor)
- ("libxinerama", libxinerama)
- ("jack", jack-1)
+ ("libxinerama" ,libxinerama)
+ ("jack" ,jack-1)
("mesa" ,mesa)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("lv2", lv2)))
+ ("lv2" ,lv2)))
(home-page "https://tytel.org/helm/")
(synopsis "Polyphonic synth with lots of modulation")
(description "Helm is a cross-platform polyphonic synthesizer available standalone
@@ -5845,9 +5845,9 @@ plugin and a standalone JACK application.")
"/lib/lv2")
"install"))))))
(inputs
- `(("lv2", lv2)))
+ `(("lv2" ,lv2)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "Audio plugin collection")
(description "TAP (Tom's Audio Processing) plugins is a collection of
audio effect plugins originally released as LADSPA plugins. This package
@@ -5903,9 +5903,9 @@ plugin and a standalone JACK application.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("jack", jack-1)
- ("lv2", lv2)
- ("mesa", mesa)))
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
(synopsis "Waveshaper plugin")
(description "Wolf Shaper is a waveshaper plugin with a graph editor.
It is provided as an LV2 plugin and as a standalone Jack application.")
@@ -5985,12 +5985,12 @@ It is provided as an LV2 plugin and as a standalone Jack application.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("cairo", cairo)
- ("glu", glu)
- ("jack", jack-1)
- ("lv2", lv2)
- ("mesa", mesa)
- ("pango", pango)))
+ `(("cairo" ,cairo)
+ ("glu" ,glu)
+ ("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)
+ ("pango" ,pango)))
(synopsis "Audio plugin collection")
(description "Shiru plugins is a collection of audio plugins created
by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8b46bd7d24..7679d62059 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3275,9 +3275,9 @@ communication over HTTP.")
("pcre2" ,pcre2)
("sobjectizer" ,sobjectizer)))
(propagated-inputs
- `(("asio", asio)
+ `(("asio" ,asio)
("fmt" ,fmt)
- ("http-parser", http-parser)))
+ ("http-parser" ,http-parser)))
(arguments
`(#:configure-flags '("-DRESTINIO_INSTALL=on")
#:tests? #f ; TODO: The tests are called from the root CMakelist, need RESTINIO_TEST=on.
diff --git a/gnu/packages/prolog.scm b/gnu/packages/prolog.scm
index 86b4bd2107..0e5f4b9b01 100644
--- a/gnu/packages/prolog.scm
+++ b/gnu/packages/prolog.scm
@@ -125,7 +125,7 @@ manner. It also features an interactive interpreter.")
("texinfo" ,texinfo)
("libarchive" ,libarchive)
("libunwind" ,libunwind)
- ("libjpeg", libjpeg-turbo)
+ ("libjpeg" ,libjpeg-turbo)
("libxft" ,libxft)
("fontconfig" ,fontconfig)
("perl" ,perl)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bb2fc850c9..dde0e447e3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4118,7 +4118,7 @@ event loop. It is implemented in Cython and uses libuv under the hood.")
#t)))))
(native-inputs
`(("binutils" ,binutils) ;; for ctypes.util.find_library()
- ("python-aiohttp", python-aiohttp)
+ ("python-aiohttp" ,python-aiohttp)
("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-sphinx" ,python-sphinx)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6c3e991de8..22a356d11b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20788,13 +20788,13 @@ content models.")
;; Testing requires undocumented setup changes, and so testing is disabled here.
(arguments `(#:tests? #f))
(propagated-inputs
- `(("python-certifi", python-certifi)
- ("python-six", python-six)
- ("python-dateutil", python-dateutil)
- ("python-urllib3", python-urllib3)
- ("python-pyjwt", python-pyjwt)
- ("python-cryptography", python-cryptography)
- ("python-nose", python-nose)))
+ `(("python-certifi" ,python-certifi)
+ ("python-six" ,python-six)
+ ("python-dateutil" ,python-dateutil)
+ ("python-urllib3" ,python-urllib3)
+ ("python-pyjwt" ,python-pyjwt)
+ ("python-cryptography" ,python-cryptography)
+ ("python-nose" ,python-nose)))
(synopsis "DocuSign Python Client")
(description "The Official DocuSign Python Client Library used to interact
with the eSign REST API. Send, sign, and approve documents using this client.")
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3266db3fe8..7348f29eb1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7792,7 +7792,7 @@ master/html-formatter/ruby")
(native-inputs
`(;; Use a untested version of aruba, to avoid a circular dependency, as
;; ruby-aruba depends on ruby-cucumber.
- ("ruby-aruba", ruby-aruba-without-tests)
+ ("ruby-aruba" ,ruby-aruba-without-tests)
("ruby-rspec" ,ruby-rspec)
("ruby-pry" ,ruby-pry)
("ruby-nokogiri" ,ruby-nokogiri)
@@ -8851,7 +8851,7 @@ display width of strings in Ruby.")
(native-inputs
`(("ruby-rdoc" ,ruby-rdoc)
("ruby-rspec" ,ruby-rspec)
- ("ruby-rubygems-tasks", ruby-rubygems-tasks)))
+ ("ruby-rubygems-tasks" ,ruby-rubygems-tasks)))
(synopsis "Ruby library to help check the Ruby version")
(description "@code{ruby_version} provides a @code{RubyVersion} module to simplify
checking for the right Ruby version in software.")
@@ -9963,7 +9963,7 @@ all known public suffixes.")
("bundler" ,bundler)
("ruby-idn-ruby" ,ruby-idn-ruby)
("ruby-sporkmonger-rack-mount" ,ruby-sporkmonger-rack-mount)
- ("ruby-rspec-its", ruby-rspec-its-minimal)
+ ("ruby-rspec-its" ,ruby-rspec-its-minimal)
("ruby-yard" ,ruby-yard)
("ruby-simplecov" ,ruby-simplecov)))
(propagated-inputs
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 8c837fdaeb..943e9ba5b9 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -59,7 +59,7 @@
`(("python-cysignals" ,python-cysignals)))
(inputs
`(("gmp" ,gmp)
- ("pari-gp", pari-gp)))
+ ("pari-gp" ,pari-gp)))
(home-page "https://cypari2.readthedocs.io/")
(synopsis
"Python interface to the number theory library libpari")
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 8032a5e505..f171967957 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -307,7 +307,7 @@ systems and other constrained environments, but they work everywhere.")))
(build-system gnu-build-system)
(inputs
`(("execline" ,execline)
- ("s6", s6)
+ ("s6" ,s6)
("skalibs" ,skalibs)))
(arguments
'(#:configure-flags
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index c704106221..d22f9ccd5d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -405,7 +405,7 @@ private network between hosts on the internet.")
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)
;; For tests only.
- ("python-flake8", python-flake8)
+ ("python-flake8" ,python-flake8)
("python-mock" ,python-mock)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-runner" ,python-pytest-runner)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 21c227d8eb..ab8daf31cf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5050,7 +5050,7 @@ written in C. It is developed as part of the NetSurf project.")
(inputs
`(("libyaml" ,libyaml)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "C library for reading and writing YAML")
(description
"LibCYAML is a C library written in ISO C11 for reading and writing
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bbbbd0d7f5..5398761c65 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2437,7 +2437,7 @@ After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(inputs
- `(("dbus-glib", dbus-glib)
+ `(("dbus-glib" ,dbus-glib)
("glib" ,glib)
("libx11" ,libx11)))
(home-page "https://github.com/qnikst/kbdd")
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8df6407e26..8ff62a1a84 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6339,7 +6339,7 @@ basic eye-candy effects.")
("python-pillow" ,python-pillow)
;; Optional dependencies.
("python-rencode" ,python-rencode) ; For speed.
- ("python-numpy", python-numpy)
+ ("python-numpy" ,python-numpy)
("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.
("python-pyopengl-accelerate" ,python-pyopengl-accelerate) ; Same.
("python-paramiko" ,python-paramiko) ; Tunneling over SSH.