summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-15 20:29:26 +0200
committerMarius Bakke <marius@gnu.org>2020-07-15 20:29:26 +0200
commit15076369062852c266bc697fc54b2ba157aceed0 (patch)
tree994a79904744f032ab30b93361bbbcea4d525f50
parentdec0217f6e21a2f48328aaff5448dcf2f4fea7d9 (diff)
downloadguix-patches-15076369062852c266bc697fc54b2ba157aceed0.tar
guix-patches-15076369062852c266bc697fc54b2ba157aceed0.tar.gz
gnu: python-tinycss2: Fix test failure.
Fixes <https://bugs.gnu.org/42372>. Reported by Michael Rohleder <mike@rohleder.de>. * gnu/packages/patches/python-tinycss2-flake8-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-web.scm (python-tinycss2)[source](patches): New field.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-tinycss2-flake8-compat.patch36
-rw-r--r--gnu/packages/python-web.scm1
3 files changed, 38 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9b42160de3..2f59279977 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1466,6 +1466,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch \
%D%/packages/patches/python-slugify-depend-on-unidecode.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
+ %D%/packages/patches/python-tinycss2-flake8-compat.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
%D%/packages/patches/python-waitress-fix-tests.patch \
diff --git a/gnu/packages/patches/python-tinycss2-flake8-compat.patch b/gnu/packages/patches/python-tinycss2-flake8-compat.patch
new file mode 100644
index 0000000000..a66eb42fa1
--- /dev/null
+++ b/gnu/packages/patches/python-tinycss2-flake8-compat.patch
@@ -0,0 +1,36 @@
+Fix test failure that occurs with recent versions of Flake8.
+
+Taken from upstream:
+https://github.com/Kozea/tinycss2/commit/6556604fb98c2153412384d6f0f705db2da1aa60
+
+diff --git a/tinycss2/css-parsing-tests/make_color3_hsl.py b/tinycss2/css-parsing-tests/make_color3_hsl.py
+index d1fd3a6..56fda0c 100644
+--- a/tinycss2/css-parsing-tests/make_color3_hsl.py
++++ b/tinycss2/css-parsing-tests/make_color3_hsl.py
+@@ -8,16 +8,17 @@ def trim(s):
+ print('[')
+ print(',\n'.join(
+ '"hsl%s(%s, %s%%, %s%%%s)", [%s, %s, %s, %s]' % (
+- ('a' if a is not None else '', h,
+- trim(str(s / 10.)), trim(str(l / 10.)),
+- ', %s' % a if a is not None else '') +
++ ('a' if alpha is not None else '', hue,
++ trim(str(saturation / 10.)), trim(str(light / 10.)),
++ ', %s' % alpha if alpha is not None else '') +
+ tuple(trim(str(round(v, 10)))
+- for v in colorsys.hls_to_rgb(h / 360., l / 1000., s / 1000.)) +
+- (a if a is not None else 1,)
++ for v in colorsys.hls_to_rgb(
++ hue / 360., light / 1000., saturation / 1000.)) +
++ (alpha if alpha is not None else 1,)
+ )
+- for a in [None, 1, .2, 0]
+- for l in range(0, 1001, 125)
+- for s in range(0, 1001, 125)
+- for h in range(0, 360, 30)
++ for alpha in [None, 1, .2, 0]
++ for light in range(0, 1001, 125)
++ for saturation in range(0, 1001, 125)
++ for hue in range(0, 360, 30)
+ ))
+ print(']')
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a7e5e7081f..1d7cfd852d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3411,6 +3411,7 @@ library to create slugs from unicode strings while keeping it DRY.")
(origin
(method url-fetch)
(uri (pypi-uri "tinycss2" version))
+ (patches (search-patches "python-tinycss2-flake8-compat.patch"))
(sha256
(base32 "1kw84y09lggji4krkc58jyhsfj31w8npwhznr7lf19d0zbix09v4"))))
(build-system python-build-system)