summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 23:33:24 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:17 +0200
commit14b0ade66fac4d8f9945f14c2031bd41352139b5 (patch)
treededfdef8001a86f1e5b85b0c1c3bb4de0dbb5b2b
parentc2828c8149ee06577c861f21acfcf4418bd711f8 (diff)
downloadguix-patches-14b0ade66fac4d8f9945f14c2031bd41352139b5.tar
guix-patches-14b0ade66fac4d8f9945f14c2031bd41352139b5.tar.gz
gnu: ghc-haskell-src-exts: Update to 1.20.2.
* gnu/packages/haskell.scm (ghc-haskell-src-exts): Update to 1.20.2. [inputs]: Replace ghc-pretty-show-for-haskell-src-exts with ghc-pretty-show. (ghc-pretty-show-for-haskell-src-exts): Remove.
-rw-r--r--gnu/packages/haskell.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0e883d1ff3..5772e6a4a4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1223,23 +1223,10 @@ complex generic values into an interactive Html page, for easier
examination.")
(license license:expat)))
-(define-public ghc-pretty-show-for-haskell-src-exts
- (package (inherit ghc-pretty-show)
- (name "ghc-pretty-show")
- (version "1.6.10")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/pretty-show/"
- "pretty-show-" version ".tar.gz"))
- (sha256
- (base32
- "133s4l1gk46saf6ycm785rswycy8g3j0qqrv93b5wp8cp50kd0ww"))))))
-
(define-public ghc-haskell-src-exts
(package
(name "ghc-haskell-src-exts")
- (version "1.20.1")
+ (version "1.20.2")
(source
(origin
(method url-fetch)
@@ -1249,12 +1236,12 @@ examination.")
".tar.gz"))
(sha256
(base32
- "1jsjl9hja2dpcfq4mzlfpwyr6axwnwgacfb7aa070kz4lbygzaa8"))))
+ "1sm3z4v1p5yffg01ldgavz71s3bvfhjfa13k428rk14bpkl8crlz"))))
(build-system haskell-build-system)
(inputs
`(("cpphs" ,cpphs)
("ghc-happy" ,ghc-happy)
- ("ghc-pretty-show" ,ghc-pretty-show-for-haskell-src-exts)))
+ ("ghc-pretty-show" ,ghc-pretty-show)))
(native-inputs
`(("ghc-smallcheck" ,ghc-smallcheck)
("ghc-tasty" ,ghc-tasty)