summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-03-02 23:30:18 +0100
committerLeo Famulari <leo@famulari.name>2017-03-15 17:17:06 -0400
commit13292ee57077be8c77aa379ea4e5f85f1e5358ef (patch)
tree983161c30f7eec1821421ce1421d5fea974200ab
parent9e61d1534a593f71fa7433fae0d4b04721b622d8 (diff)
downloadguix-patches-13292ee57077be8c77aa379ea4e5f85f1e5358ef.tar
guix-patches-13292ee57077be8c77aa379ea4e5f85f1e5358ef.tar.gz
gnu: Add libmesode.
* gnu/packages/messaging.scm (libmesode): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/messaging.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4e40567b1c..c14fb72386 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1222,4 +1223,39 @@ is also scriptable and extensible via Guile.")
(home-page "https://www.gnu.org/software/freetalk")
(license license:gpl3+)))
+(define-public libmesode
+ (package
+ (name "libmesode")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/boothj5/libmesode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0iaj56fkd5bjvqpvq3324ni895rmbj1akbfqipjydnghfwaym4z6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "./bootstrap.sh")))))))
+ (inputs
+ `(("expat" ,expat)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "C library for writing XMPP clients")
+ (description "Libmesode is a fork of libstrophe for use with Profanity
+XMPP Client. In particular, libmesode provides extra TLS functionality such as
+manual SSL certificate verification.")
+ (home-page "https://github.com/boothj5/libmesode")
+ ;; Dual licensed.
+ (license (list license:gpl3+ license:x11))))
+
;;; messaging.scm ends here