summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-08-29 08:55:59 +0000
committerLudovic Courtès <ludo@gnu.org>2022-09-01 00:57:10 +0200
commit130f65423b5b1918c9cd3af39392526fb15ac6c6 (patch)
tree0c66bcbf2845e4d41b9bfe0444a21929ac8d0bd1
parent80df3ffb4fba19c9711ca912503df01cd2c9dc96 (diff)
downloadguix-patches-130f65423b5b1918c9cd3af39392526fb15ac6c6.tar
guix-patches-130f65423b5b1918c9cd3af39392526fb15ac6c6.tar.gz
gnu: Add guile-srfi-128.
* gnu/packages/guile-xyz.scm (guile-srfi-128): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a85c7e0fc4..02680e7860 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3086,6 +3086,36 @@ pre-alpha code.")
parameters, which define* and lambda* special forms")
(license license:gpl3+)))
+(define-public guile-srfi-128
+ (package
+ (name "guile-srfi-128")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://inqlab.net/git/guile-srfi-128.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "03d85q5l2gc2c8cmri6zd4pfndvnadlhwh77hsx6ixvvm8vwq4sy"))
+ (file-name (git-file-name name version))))
+ (build-system guile-build-system)
+ (native-inputs
+ (list guile-3.0))
+ (home-page "https://inqlab.net/git/guile-srfi-128.git")
+ (synopsis "SRFI 128 Comparators (reduced) port for Guile")
+ (description
+ "This package provides an implementation of SRFI 128 for Guile.
+SRFI 128 defines comparators, which bundles a test type predicate, an
+equality predicate, an ordering predicate and a hash function into a
+single Scheme object. This can be used in the implementation of data
+structures. This package re-uses the SRFI sample implementation.")
+ (license
+ (list license:lgpl3+
+ ;; contains ISC code from the SRFI sample implementation
+ license:isc))))
+
(define-public guile-srfi-145
(package
(name "guile-srfi-145")