summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfesoj000 <fesoj000@gmail.com>2022-03-27 00:34:17 +0100
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:48:28 +0200
commit0f31129e4e9864938fadf7ac1b33290c377e579b (patch)
tree76b2c41f7f8adb775037c74d8f54386eade79b35
parent469f85d206604fdf7129ce4cfd0883b402297395 (diff)
downloadguix-patches-0f31129e4e9864938fadf7ac1b33290c377e579b.tar
guix-patches-0f31129e4e9864938fadf7ac1b33290c377e579b.tar.gz
gnu: Add libnetfilter-cttimeout
* gnu/packages/linux.scm (libnetfilter-cttimeout): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4824f8e7b8..778a757d8b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7322,6 +7322,32 @@ conntrack-tools among many other applications.")
(supported-systems (filter target-linux? %supported-systems))
(license license:gpl2+)))
+(define-public libnetfilter-cttimeout
+ (package
+ (name "libnetfilter-cttimeout")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://netfilter.org/projects/"
+ "libnetfilter_cttimeout/files/"
+ "libnetfilter_cttimeout-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1fpyz1zlvcq80244knvyvy87909xjqlj02lmw8yblz2m9xsi5axf"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libmnl))
+ (synopsis "Library for kernel connection tracking timeout infrastructure")
+ (description "libnetfilter_cttimeout is the userspace library that
+provides the programming interface to the fine-grain connection tracking
+timeout infrastructure. With this library, you can create, update and delete
+timeout policies that can be attached to traffic flows. This library is used
+by conntrack-tools.")
+ (home-page "https://netfilter.org/projects/libnetfilter_cttimeout/index.html")
+ (supported-systems (filter target-linux? %supported-systems))
+ (license license:gpl2)))
+
(define-public proot
(package
(name "proot")