summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-02-20 15:01:07 +0100
committerGuix Patches Tester <>2020-02-20 14:03:06 +0000
commit0eef914f74f2b1908271015a4f0416be57cc676a (patch)
treecfd5fa21b8de335bf51c29cc34369b8a53b3f67d
parentbf8dfe3df025e4ac80cccb87497b4f072ba10e2a (diff)
downloadguix-patches-0eef914f74f2b1908271015a4f0416be57cc676a.tar
guix-patches-0eef914f74f2b1908271015a4f0416be57cc676a.tar.gz
gnu: Add pm_pcie_driver.
* gnu/packages/linux.scm (pm_pcie_driver): New variable.
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0fd2fb5df..3e45cad77e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1046,6 +1046,26 @@ module allows the control of the backlight level or luminance property when
supported under @file{/sys/class/backlight/}.")
(license license:gpl2+)))
+(define-public pm_pcie_driver
+ (package
+ (name "pm_pcie_driver")
+ (version "2.0.1000")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.passmark.com/downloads/pm_pcie_driver.tar.gz")
+ (sha256
+ (base32
+ "0xxyr7xi3j8v64yixzw01w7hi0c8pvd21wyr3k8fjiilvls2x9iw"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://www.passmark.com/products/pcie-test-card/index.php")
+ (synopsis "Passmark PCIe test card driver")
+ (description "This package provides a Linux kernel driver for the Passmark
+PCIe test card.")
+ (license license:gpl2+)))
+
;;;
;;; Pluggable authentication modules (PAM).