summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-09-01 21:18:44 +0300
committerAlex Kost <alezost@gmail.com>2015-09-02 21:47:22 +0300
commit0b928076c748789f62e0761e8f01f5090c34a8af (patch)
treef9cc063f7ef8529e7d8c83ccfea8ef156c8ff14d
parentd1f80aa401a331072f5c4b837d81c659fe6b5fd1 (diff)
downloadguix-patches-0b928076c748789f62e0761e8f01f5090c34a8af.tar
guix-patches-0b928076c748789f62e0761e8f01f5090c34a8af.tar.gz
gnu: emacs-flycheck: Use the upstream release instead of MELPA.
* gnu/packages/emacs.scm (flycheck): Change version to 0.23. Replace MELPA tarball with the upstream release.
-rw-r--r--gnu/packages/emacs.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 57d45c22b3..594e842008 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -537,14 +537,15 @@ the body are let-bound and this search is done at compile time.")
(define-public flycheck
(package
(name "emacs-flycheck")
- (version "20150831.1343")
+ (version "0.23")
(source (origin
(method url-fetch)
- (uri (string-append "http://melpa.org/packages/flycheck-"
- version ".tar"))
+ (uri (string-append
+ "https://github.com/flycheck/flycheck/releases/download/"
+ version "/flycheck-" version ".tar"))
(sha256
(base32
- "0a0iyvki62rqi24dbrcdq3i1wdygdi350gcjsfrfr6fz8fasz42l"))))
+ "1n2cifzsl5dbv42l82bi3y1vk6q33msi8dd4bj7b9nvnl9jfjj5b"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)