summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-19 00:01:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-21 22:59:47 +0100
commit0b57c1b09efb74f0b30fd74c7c1eb2da1f5957bc (patch)
tree24dab60108d3e1744896aed2ca81f09e7270704a
parent3b2a26219f4291565edc39f5e48a8c9b3ca76381 (diff)
downloadguix-patches-0b57c1b09efb74f0b30fd74c7c1eb2da1f5957bc.tar
guix-patches-0b57c1b09efb74f0b30fd74c7c1eb2da1f5957bc.tar.gz
gnu: Rename escpr to epson-inkjet-printer-escpr.
‘escpr’ is nice and short, but everyone else calls this package ‘epson-inkjet-printer-escpr’. More importantly, so does upstream. * gnu/packages/cups.scm (escpr, epson-inkjet-printer-escpr,): Rename escpr to epson-inkjet-printer-escpr, redefining escpr as deprecated-package. Adjust all users.
-rw-r--r--doc/guix.texi11
-rw-r--r--gnu/packages/cups.scm7
-rw-r--r--gnu/services/cups.scm3
3 files changed, 13 insertions, 8 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index d021384b73..1f1510f5f5 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -17503,16 +17503,17 @@ CUPS service will generate a self-signed certificate if needed, for
secure connections to the print server.
Suppose you want to enable the Web interface of CUPS and also add
-support for Epson printers @i{via} the @code{escpr} package and for HP
-printers @i{via} the @code{hplip-minimal} package. You can do that directly,
-like this (you need to use the @code{(gnu packages cups)} module):
+support for Epson printers @i{via} the @code{epson-inkjet-printer-escpr}
+package and for HP printers @i{via} the @code{hplip-minimal} package.
+You can do that directly, like this (you need to use the
+@code{(gnu packages cups)} module):
@lisp
(service cups-service-type
(cups-configuration
(web-interface? #t)
(extensions
- (list cups-filters escpr hplip-minimal))))
+ (list cups-filters epson-inkjet-printer-escpr hplip-minimal))))
@end lisp
Note: If you wish to use the Qt5 based GUI which comes with the hplip
@@ -17541,7 +17542,7 @@ Available @code{cups-configuration} fields are:
The CUPS package.
@end deftypevr
-@deftypevr {@code{cups-configuration} parameter} package-list extensions (default: @code{(list escpr hplip-minimal foomatic-filters)})
+@deftypevr {@code{cups-configuration} parameter} package-list extensions (default: @code{(list epson-inkjet-printer-escpr hplip-minimal foomatic-filters)})
Drivers and other extensions to the CUPS package.
@end deftypevr
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index b2d7b952b9..bfe24027fb 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -744,9 +744,9 @@ HP@tie{}LaserJet, and possibly other printers. See @file{README} for details.")
(license (list license:expat ; icc2ps/*.[ch]
license:gpl2+)))) ; everything else
-(define-public escpr
+(define-public epson-inkjet-printer-escpr
(package
- (name "escpr")
+ (name "epson-inkjet-printer-escpr")
(version "1.7.8")
;; XXX: This currently works. But it will break as soon as a newer
;; version is available since the URLs for older versions are not
@@ -806,6 +806,9 @@ language.")
(home-page "http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX")
(license license:gpl2+)))
+(define-public escpr
+ (deprecated-package "escpr" epson-inkjet-printer-escpr))
+
(define-public splix
;; Last released in 2009 <https://sourceforge.net/projects/splix/files/>.
;; Last SVN commit was 2013 <https://svn.code.sf.net/p/splix/code/splix/>.
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 7d2defacaa..6194fc37ad 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -482,7 +482,8 @@ programs.")
(package cups)
"The CUPS package.")
(extensions
- (package-list (list cups-filters escpr hplip-minimal foomatic-filters))
+ (package-list (list cups-filters epson-inkjet-printer-escpr
+ foomatic-filters hplip-minimal))
"Drivers and other extensions to the CUPS package.")
(files-configuration
(files-configuration (files-configuration))