summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-27 10:59:55 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-27 10:59:55 +0100
commit09bba548bf09dcfb958bf1be28bc426458c00a40 (patch)
tree2cab0d6eb89d88f5bd82d837f778580d04427269
parent1aee32a26e1a96dd457fcf62f97f514c7a562475 (diff)
downloadguix-patches-09bba548bf09dcfb958bf1be28bc426458c00a40.tar
guix-patches-09bba548bf09dcfb958bf1be28bc426458c00a40.tar.gz
gnu: sbcl-slynk: Fix version number check.
* gnu/packages/lisp-xyz.scm (sbcl-slynk)[source]: Don't move files around since this is not required. [arguments]: Re-enable tests. There is none at the moment, but they might get added in the future. Don't list systems since they are found automatically. Moving `slynk.lisp' had the detrimental side-effect to break `sly-version-string' which expects `sly.el' to be in the parent directory. As a result, using `sly-connect' from Emacs would prompt the user: [sly] Versions differ: 1.0.43 (sly) vs. nil (slynk). Continue? (y or n) even though the Slynk version is correct. Maybe there was a need for moving files around in the past, but since our ASDF build system got revamped, all systems are now automatically found. Thus we can leave the files where they are, which fixes the version number check.
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 2 insertions, 31 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 73ac0dcb80..bc959502be 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -832,40 +832,11 @@ antialiased TrueType font rendering using CLX and XRender extension.")
(commit commit)))
(sha256
(base32 "0vv185gz3rkfng5y79dijfnc11p92qdz2kdza05avjbpqfs6l0zn"))
- (file-name (git-file-name "slynk" version))
- (modules '((guix build utils)
- (ice-9 ftw)))
- (snippet
- '(begin
- ;; Move the contribs into the main source directory for easier
- ;; access
- (substitute* "slynk/slynk.asd"
- (("\\.\\./contrib")
- "contrib"))
- (rename-file "contrib" "slynk/contrib")
- ;; Move slynk's contents into the base directory for easier
- ;; access
- (for-each (lambda (file)
- (unless (string-prefix? "." file)
- (rename-file (string-append "slynk/" file)
- (string-append "./" (basename file)))))
- (scandir "slynk"))
- #t))))
+ (file-name (git-file-name "slynk" version))))
(build-system asdf-build-system/sbcl)
(outputs '("out" "image"))
(arguments
- `(#:tests? #f ; No test suite
- #:asd-systems '("slynk"
- "slynk/arglists"
- "slynk/fancy-inspector"
- "slynk/package-fu"
- "slynk/mrepl"
- "slynk/trace-dialog"
- "slynk/profiler"
- "slynk/stickers"
- "slynk/indentation"
- "slynk/retro")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'create-asdf-configuration 'build-image
(lambda* (#:key outputs #:allow-other-keys)