summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-24 15:24:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-24 16:08:37 -0400
commit07f55a361e23152b48f34425f116a725cce39e48 (patch)
tree708b0348368f270ee396d27c3ef0c75b78b91c9f
parentd8f62653e5810beceff79b8fe655715734a8dcee (diff)
downloadguix-patches-07f55a361e23152b48f34425f116a725cce39e48.tar
guix-patches-07f55a361e23152b48f34425f116a725cce39e48.tar.gz
gnu: Add python-robotframework-pabot.
* gnu/packages/python-xyz.scm (python-robotframework-pabot): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0224573f0..739697b10f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4839,6 +4839,38 @@ data files in the CSV, XLS or XLSX formats.")
utility, a static analysis tool (linter) for Robot Framework source files.")
(license license:asl2.0))))
+(define-public python-robotframework-pabot
+ (package
+ (name "python-robotframework-pabot")
+ (version "2.5.2")
+ (source
+ (origin
+ ;; There are no tests in the PyPI archive.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkorpela/pabot")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14a8isq1f4lgfwjb84hhzg6jm7ns18dxa9bg6dy8k2ml8zl0qknk"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests")))))))
+ (propagated-inputs
+ (list python-robotframework python-robotframework-stacktrace))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://pabot.org")
+ (synopsis "Parallel test runner for Robot Framework")
+ (description "Pabot is a parallel executor for Robot Framework tests.")
+ (license license:asl2.0)))
+
(define-public python-robotframework-stacktrace
(package
(name "python-robotframework-stacktrace")