summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-01 00:00:06 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commit073f5ae1fe78de76c46659e4c938f1b8ef84652a (patch)
tree76ccda3ce7ca411d20d1a2c685bb7d3a0d40a2fe
parent1cf4f2729f05872eb3d7a2eade1bde5120e502f8 (diff)
downloadguix-patches-073f5ae1fe78de76c46659e4c938f1b8ef84652a.tar
guix-patches-073f5ae1fe78de76c46659e4c938f1b8ef84652a.tar.gz
gnu: Add ghc-newtype-generics.
* gnu/packages/haskell.scm (ghc-newtype-generics): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3a607bfb4e..5c49e9074a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -823,6 +823,32 @@ code pages on Windows. On all other operating systems, the library does
nothing.")
(license license:bsd-3)))
+(define-public ghc-newtype-generics
+ (package
+ (name "ghc-newtype-generics")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "newtype-generics/newtype-generics-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0igyisw2djg19v9vkna1rwf47k97mvkvk4bbkmswznvbm00z15gj"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "http://github.com/sjakobi/newtype-generics")
+ (synopsis "Typeclass and set of functions for working with newtypes")
+ (description "The @code{Newtype} typeclass represents the packing and
+unpacking of a newtype, and allows you to operate under that newtype with
+functions such as @code{ala}. Generics support was added in version 0.4,
+making this package a full replacement for the original newtype package,
+and an alternative to newtype-th.")
+ (license license:bsd-3)))
+
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")