summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-25 07:55:07 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:13 -0500
commit05b29d84949acb6b7ce7524e06c5114834053b40 (patch)
tree452abda394d655f586618bc6ba4478f662d932bc
parent20db7a3d4c039c49e14616f55a0136b8180058c3 (diff)
downloadguix-patches-05b29d84949acb6b7ce7524e06c5114834053b40.tar
guix-patches-05b29d84949acb6b7ce7524e06c5114834053b40.tar.gz
gnu: python-pyatspi: Update to 2.32.1.
* gnu/packages/gnome.scm (python-pyatspi): Update to 2.32.1. [source]: Remove patch. * gnu/packages/patches/python-pyatspi-python-37.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/patches/python-pyatspi-python-37.patch82
3 files changed, 2 insertions, 87 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7744566996..b2938e878b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1296,7 +1296,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
- %D%/packages/patches/python-pyatspi-python-37.patch \
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 504bc346e1..c25e1a4560 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7944,7 +7944,7 @@ kill/reinice processes.")
(define-public python-pyatspi
(package
(name "python-pyatspi")
- (version "2.26.0")
+ (version "2.32.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -7953,9 +7953,7 @@ kill/reinice processes.")
"/pyatspi-" version ".tar.xz"))
(sha256
(base32
- "0xdnix7gxzgf75xy9ris4dd6b05mqwicw190b98xqmypydyf95n6"))
- ;; Patch from upstream, fixed in newer versions.
- (patches (search-patches "python-pyatspi-python-37.patch"))))
+ "1283cbwd2kacgdij96xk26721f6amyzdhy2py11kdj5cprdlm5c4"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/python-pyatspi-python-37.patch b/gnu/packages/patches/python-pyatspi-python-37.patch
deleted file mode 100644
index caa6aea39e..0000000000
--- a/gnu/packages/patches/python-pyatspi-python-37.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 29a7b929f7f1160b643dc5f5911533887173fcff Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
-Date: Thu, 28 Jun 2018 17:10:33 +0200
-Subject: [PATCH] Rename async to asynchronous, keep backwards comaptibility
-
-async is a keyword in Python 3.7 and keeping it results in SyntaxError.
-
-Fixes https://gitlab.gnome.org/GNOME/pyatspi2/issues/1
----
- pyatspi/registry.py | 35 +++++++++++++++++++++++++++--------
- 1 file changed, 27 insertions(+), 8 deletions(-)
-
-diff --git a/pyatspi/registry.py b/pyatspi/registry.py
-index cb28395..f73ee16 100644
---- a/pyatspi/registry.py
-+++ b/pyatspi/registry.py
-@@ -50,9 +50,9 @@ class Registry(object):
- reference to the Accessibility.Registry singleton. Doing so is harmless and
- has no point.
-
-- @@ivar async: Should event dispatch to local listeners be decoupled from event
-- receiving from the registry?
-- @@type async: boolean
-+ @@ivar asynchronous: Should event dispatch to local listeners be decoupled
-+ from event receiving from the registry?
-+ @@type asynchronous: boolean
- @@ivar reg: Reference to the real, wrapped registry object
- @@type reg: Accessibility.Registry
- @@ivar dev: Reference to the device controller
-@@ -111,25 +111,44 @@ class Registry(object):
-
- self.has_implementations = True
-
-- self.async = False # not fully supported yet
-+ self.asynchronous = False # not fully supported yet
- self.started = False
- self.event_listeners = dict()
-
-+ def __getattr__(self, name):
-+ """
-+ For backwards compatibility with old API
-+ """
-+ if name == 'async':
-+ return self.asynchronous
-+ return object.__getattr__(self, name)
-+
-+ def __setattr__(self, name, value):
-+ """
-+ For backwards compatibility with old API
-+ """
-+ if name == 'async':
-+ self.asynchronous = value
-+ object.__setattr__(self, name, value)
-+
- def _set_default_registry (self):
- self._set_registry (MAIN_LOOP_GLIB)
-
-- def start(self, async=False, gil=True):
-+ def start(self, asynchronous=False, gil=True, **kwargs):
- """
- Enter the main loop to start receiving and dispatching events.
-
-- @@param async: Should event dispatch be asynchronous (decoupled) from
-- event receiving from the AT-SPI registry?
-- @@type async: boolean
-+ @@param asynchronous: Should event dispatch be asynchronous
-+ (decoupled) from event receiving from the AT-SPI registry?
-+ @@type asynchronous: boolean
- @@param gil: Add an idle callback which releases the Python GIL for a few
- milliseconds to allow other threads to run? Necessary if other threads
- will be used in this process.
- @@type gil: boolean
- """
-+ if 'async' in kwargs:
-+ # support previous API
-+ asynchronous = kwargs['async']
- if not self.has_implementations:
- self._set_default_registry ()
- self.started = True
---
-2.22.0
-