summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-17 23:58:58 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-17 23:58:58 +0100
commit05093579e9ac6ffebc546524ad90c8aaedd1c89b (patch)
tree469ac0cb92126bda70459c42099cb6592648cd51
parent90422555f114d3af35e7cc4b5b6d59a5c226adc4 (diff)
downloadguix-patches-05093579e9ac6ffebc546524ad90c8aaedd1c89b.tar
guix-patches-05093579e9ac6ffebc546524ad90c8aaedd1c89b.tar.gz
gnu: Add perl-digest-sha1.
* gnu/packages/perl.scm (perl-digest-sha1): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 164f6bd099..8d71660180 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -141,3 +141,23 @@ pseudo ttys.")
manipulate, read, and write Zip archive files.")
(home-page "http://search.cpan.org/~phred/Archive-Zip-1.37/lib/Archive/Zip.pm")
(license (package-license perl))))
+
+(define-public perl-digest-sha1
+ (package
+ (name "perl-digest-sha1")
+ (version "2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GA/GAAS/"
+ "Digest-SHA1-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k23p5pjk42vvzg8xcn4iwdii47i0qm4awdzgbmz08bl331dmhb8"))))
+ (build-system perl-build-system)
+ (synopsis "Perl implementation of the SHA-1 message digest algorithm")
+ (description
+ "This package provides 'Digest::SHA1', an implementation of the NIST
+SHA-1 message digest algorithm for use by Perl programs.")
+ (home-page (string-append "http://search.cpan.org/~gaas/Digest-SHA1-"
+ version "/SHA1.pm"))
+ (license (package-license perl))))