summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-12-02 12:24:40 +0300
committerAlex Kost <alezost@gmail.com>2016-12-04 17:39:48 +0300
commit023f0fb06ee8dd55f95ff1be542e805363535b97 (patch)
tree513d311fdf5409071022c083e656ec71a9e9c8d9
parentc3a10d30d15d7f4b70c9f23cc20a498079fcf77f (diff)
downloadguix-patches-023f0fb06ee8dd55f95ff1be542e805363535b97.tar
guix-patches-023f0fb06ee8dd55f95ff1be542e805363535b97.tar.gz
gnu: exiv2: Move to (gnu packages image).
* gnu/packages/geeqie.scm (exiv2): Move to... * gnu/packages/image.scm: ... here. * gnu/packages/gnome.scm: Adjust the used modules. * gnu/packages/gnunet.scm: Likewise. * gnu/packages/gps.scm: Likewise.
-rw-r--r--gnu/packages/geeqie.scm33
-rw-r--r--gnu/packages/gnome.scm1
-rw-r--r--gnu/packages/gnunet.scm1
-rw-r--r--gnu/packages/gps.scm2
-rw-r--r--gnu/packages/image-viewers.scm2
-rw-r--r--gnu/packages/image.scm35
6 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/geeqie.scm b/gnu/packages/geeqie.scm
index 509819e780..bc922d577a 100644
--- a/gnu/packages/geeqie.scm
+++ b/gnu/packages/geeqie.scm
@@ -31,39 +31,6 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml))
-(define-public exiv2 ; XXX: move elsewhere?
- (package
- (name "exiv2")
- (version "0.25")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "http://www.exiv2.org/exiv2-"
- version ".tar.gz")
- (string-append "https://fossies.org/linux/misc/exiv2-"
- version ".tar.gz")))
- (sha256
- (base32
- "197g6vgcpyf9p2cwn5p5hb1r714xsk1v4p96f5pv1z8mi9vzq2y8"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no `check' target
- (propagated-inputs
- `(("expat" ,expat)
- ("zlib" ,zlib)))
- (native-inputs
- `(("intltool" ,intltool)))
- (home-page "http://www.exiv2.org/")
- (synopsis "Library and command-line utility to manage image metadata")
- (description
- "Exiv2 is a C++ library and a command line utility to manage image
-metadata. It provides fast and easy read and write access to the Exif, IPTC
-and XMP metadata of images in various formats.")
-
- ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
- ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
- ;; The core is GPLv2+:
- ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
- (license l:gpl2+)))
-
(define-public geeqie
(package
(name "geeqie")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3aa0f567fd..e7798e9399 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -97,7 +97,6 @@
#:use-module (gnu packages scanner)
#:use-module (gnu packages ssh)
#:use-module (gnu packages xml)
- #:use-module (gnu packages geeqie)
#:use-module (gnu packages gl)
#:use-module (gnu packages compression)
#:use-module (gnu packages tex)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1eb2670743..5d1baa834e 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -29,7 +29,6 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
- #:use-module (gnu packages geeqie)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index da5485e6ee..bc0f3ed115 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -27,7 +27,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression)
#:use-module (gnu packages docbook)
- #:use-module (gnu packages geeqie) ;exiv2
+ #:use-module (gnu packages image)
#:use-module (gnu packages xml)
#:use-module (gnu packages gtk)
#:use-module (gnu packages qt))
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 4be0ebbc2d..eb25c11fd4 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -20,10 +20,10 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
- #:use-module (gnu packages geeqie)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config))
(define-public viewnior
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3f9a2b2a4f..35abe9e911 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
@@ -40,6 +41,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages graphics)
#:use-module (gnu packages maths)
#:use-module (gnu packages mcrypt)
@@ -788,6 +790,39 @@ channels.")
"Libmng is the MNG (Multiple-image Network Graphics) reference library.")
(license license:bsd-3)))
+(define-public exiv2
+ (package
+ (name "exiv2")
+ (version "0.25")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "http://www.exiv2.org/exiv2-"
+ version ".tar.gz")
+ (string-append "https://fossies.org/linux/misc/exiv2-"
+ version ".tar.gz")))
+ (sha256
+ (base32
+ "197g6vgcpyf9p2cwn5p5hb1r714xsk1v4p96f5pv1z8mi9vzq2y8"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no `check' target
+ (propagated-inputs
+ `(("expat" ,expat)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("intltool" ,intltool)))
+ (home-page "http://www.exiv2.org/")
+ (synopsis "Library and command-line utility to manage image metadata")
+ (description
+ "Exiv2 is a C++ library and a command line utility to manage image
+metadata. It provides fast and easy read and write access to the Exif, IPTC
+and XMP metadata of images in various formats.")
+
+ ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
+ ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
+ ;; The core is GPLv2+:
+ ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
+ (license license:gpl2+)))
+
(define-public devil
(package
(name "devil")