summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Huijzer <ikbenrickhuyzer@gmail.com>2024-07-16 17:23:06 +0200
committerGuix Patches Tester <>2024-07-16 17:50:22 +0200
commit9735774dca788c0e3f550f22af4dddbfb3695465 (patch)
treefc7a0d4f32f9b38e00c40bbd2e39294bcb17ede7
parent3c58b759a51072aabd7eaaca680674a0c2b36c23 (diff)
downloadguix-patches-issue-72142.tar
guix-patches-issue-72142.tar.gz
add python-rtmidiissue-72142
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4d7ddeb9d7..8f8cf4a1a8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24710,6 +24710,32 @@ manipulation, or @code{stdout}.")
a network.")
(license license:expat)))
+(define-public python-rtmidi
+ (package
+ (name "python-rtmidi")
+ (version "1.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python_rtmidi" version))
+ (sha256
+ (base32 "1yh4s124awzwhfg49m8s6qsa58qxabljlmnb1q00kbk8n1ldx6kz"))))
+ (build-system meson-build-system)
+ (inputs
+ (list glibc
+ python-cffi
+ jack-2
+ boost
+ rtmidi))
+ (native-inputs (list python python-pytest pkg-config python-setuptools))
+ (home-page "https://pypi.org/project/python-rtmidi/")
+ (synopsis "Python bindings for RtMidi")
+ (description
+ "Python-rtmidi is a Python binding for RtMidi, a set of C++ classes that provides
+ a common API for real-time MIDI input/output across Linux (ALSA & JACK), macOS,
+ and Windows (Multimedia Library).")
+ (license license:expat)))
+
(define-public python-bagit
(package
(name "python-bagit")