summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Szmulewicz <daniel.szmulewicz@gmail.com>2024-07-14 18:23:33 +0300
committerGuix Patches Tester <>2024-07-14 18:01:05 +0200
commit2b74bee84f26384b645d84e56cdd2075f624e741 (patch)
tree5b220bd6feacec27c7078501ec0a298f0425a972
parentc1d367f57e89c3f2efd964e6d638bd89b0b1df97 (diff)
downloadguix-patches-issue-72114.tar
guix-patches-issue-72114.tar.gz
gnu: Add emacs-flycheck-clj-kondoissue-72114
* gnu/packages/emacs-xyz.scm (emacs-flycheck-clj-kondo): New variable. Change-Id: Idc97832c7d3ae546152cb9458b07724e154bcb27
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 99e1d4c65c..41ada4801d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2773,6 +2773,30 @@ different tools. It highlights errors and warnings inline in the buffer, and
provides an optional IDE-like error list.")
(license license:gpl3+))) ;+GFDLv1.3+ for the manual
+(define-public emacs-flycheck-clj-kondo
+ (package
+ (name "emacs-flycheck-clj-kondo")
+ (version "0.0.4-snapshot")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/borkdude/flycheck-clj-kondo.git")
+ (commit "e38c67ba9db1ea1cbe1b61ab39b506c05efdcdbf")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pxlb8axgmc8cw4id40z576kd041qb1irq8rkjn6xbda585ix58f"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-flycheck))
+ (home-page "https://github.com/borkdude/flycheck-clj-kondo")
+ (synopsis "Add clj-kondo linter to flycheck")
+ (description
+ "This package integrates clj-kondo with Emacs via flycheck. To use it, add to
+your init.el: (require flycheck-clj-kondo) Make sure the clj-kondo binary is on
+your path. For installation instructions, see
+https://github.com/borkdude/clj-kondo.")
+ (license license:gpl3+)))
+
(define-public emacs-fb2-reader
(let ((commit "9836db284749e0cef4c43c2cb5358c82ae9b8589")) ; version bump
(package