summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-07-14 17:17:40 +0200
committerGuix Patches Tester <>2024-07-14 18:00:53 +0200
commit763cbf92118835d5b1927bf73542a64fb744885b (patch)
tree807ac86da594007d51998003201c72442ec0ee1c
parentc1d367f57e89c3f2efd964e6d638bd89b0b1df97 (diff)
downloadguix-patches-issue-72113.tar
guix-patches-issue-72113.tar.gz
gnu: rapidcheck: Disable failing tests on aarch64.issue-72113
* gnu/packages/check.scm (rapidcheck): Disable failing tests on aarch64. Change-Id: I9b4e7be2acad615cc1586adb37cc39b43590b2d8
-rw-r--r--gnu/packages/check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3bfcf5a37e..412b94569c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3500,7 +3500,13 @@ provides a simple way to achieve this.")
(display "find_package(Boost GLOBAL)\n" out)))
(substitute* "extras/boost/test/CMakeLists.txt"
(("^([ ]*)boost" all spaces)
- (string-append spaces "Boost::boost")))))))
+ (string-append spaces "Boost::boost")))
+ ;; Disable tests failing on Apple M1 and Hetzner CAX41 (aarch64).
+ ;; Upstream issue: https://github.com/emil-e/rapidcheck/issues/328
+ (substitute* "test/gen/NumericTests.cpp"
+ (("forEachType<SignedProperties.*") ""))
+ (substitute* "test/shrink/ShrinkTests.cpp"
+ (("forEachType<SignedIntegralProperties.*") ""))))))
(arguments
(list
#:configure-flags #~(list "-DCMAKE_POSITION_INDEPENDENT_CODE=ON"