summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Szmulewicz <daniel.szmulewicz@gmail.com>2024-07-14 18:10:42 +0300
committerGuix Patches Tester <>2024-07-14 18:00:28 +0200
commitb7879c3c0453f9f97a09b3ae407bd0b2edc225a3 (patch)
treefceb61974b8d49e7ce1593bbb52b529176e5ea5e
parentc1d367f57e89c3f2efd964e6d638bd89b0b1df97 (diff)
downloadguix-patches-issue-72112.tar
guix-patches-issue-72112.tar.gz
gnu: Add emacs-consult-projectileissue-72112
* gnu/packages/emacs-xyz.scm (emacs-consult-projectile): New variable. Change-Id: Id7de103e052b0900069757fe56ddc1b10a875660
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 99e1d4c65c..d735e9b5bd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39846,6 +39846,30 @@ workspace diagnostics, symbols, and file symbols from @{emacs-lsp-mode}
by leveraging @code{emacs-consult} APIs.")
(license license:expat)))
+(define-public emacs-consult-projectile
+ (package
+ (name "emacs-consult-projectile")
+ (version "0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/OlMon/consult-projectile")
+ (commit "400439c56d17bca7888f7d143d8a11f84900a406")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1abd2dw3zpiln9pd7l3j78wl3lwapcmf1ilijv3vin9g0wqb7hmn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult emacs-projectile))
+ (home-page "https://gitlab.com/OlMon/consult-projectile")
+ (synopsis "Consult integration for projectile")
+ (description
+ "This package provides a multiview for displaying open buffers, files and
+directories accociated with a project. When no project is open in the current
+buffer display a list of known project and select a file from the selected
+project. Additionally seperate single source function are available.")
+ (license license:gpl3+)))
+
(define-public emacs-context-transient
(package
(name "emacs-context-transient")