summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-14 13:35:45 +0000
committerGuix Patches Tester <>2024-07-14 15:58:18 +0200
commit8100bba87c9a88e6774cd48b1770af130b18a6cb (patch)
treeffed8d216185b87512b926989a478b080062d493
parenta4ace3e97644966c6c5f87d9794623ff3982ae9c (diff)
downloadguix-patches-issue-72108.tar
guix-patches-issue-72108.tar.gz
gnu: librepcb: Update to 1.1.0.issue-72108
* gnu/packages/engineering.scm (librepcb): Update to 1.1.0. [source, arguments]: Rename "fontobene-qt5" to "fontobene-qt". <#:phases>: Skip a failing test in the check phase. [inputs]: Replace fontobene-qt5 by fontobene-qt. Change-Id: I5baa341f52a265ab487248a61d7ef8890af09b07
-rw-r--r--gnu/packages/engineering.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cc9020c6fd..f90ec64d27 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2309,7 +2309,7 @@ parallel computing platforms. It also supports serial execution.")
(define-public librepcb
(package
(name "librepcb")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -2320,7 +2320,7 @@ parallel computing platforms. It also supports serial execution.")
;; Delete libraries that we already have or don't need.
;; TODO: try to unbundle more (see lib/).
`(begin
- (let ((third-parties '("fontobene-qt5"
+ (let ((third-parties '("fontobene-qt"
"googletest"
"hoedown"
"muparser"
@@ -2331,12 +2331,12 @@ parallel computing platforms. It also supports serial execution.")
(delete-file-recursively third-party))
third-parties)))))
(sha256
- (base32 "02qfwyhdq1pklb5gkwn3rbsdhwvcgiksd21swaphz3kw6s4p9i8v"))))
+ (base32 "10wfjmzaghg5k3fvpxa610rxjnfcj9si8pkbw8iaz6gq7iqwsb8h"))))
(build-system cmake-build-system)
(inputs
(list clipper
fontconfig
- fontobene-qt5
+ fontobene-qt
glu
hoedown
muparser
@@ -2354,7 +2354,7 @@ parallel computing platforms. It also supports serial execution.")
unzip))
(arguments
`(#:configure-flags (list
- "-DUNBUNDLE_FONTOBENE_QT5=ON"
+ "-DUNBUNDLE_FONTOBENE_QT=ON"
"-DUNBUNDLE_GTEST=ON"
"-DUNBUNDLE_HOEDOWN=ON"
"-DUNBUNDLE_MUPARSER=ON"
@@ -2367,6 +2367,7 @@ parallel computing platforms. It also supports serial execution.")
(let ((test-include (list "*"))
(test-exclude
(list
+ "ApplicationTest.testGetCacheDir"
;; These tests all fail when run by the build
;; process even though they pass when manually
;; run as a normal user.