summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-07-14 12:10:16 +0900
committerGuix Patches Tester <>2024-07-14 13:03:29 +0200
commit6bb380cd39691d53f2c1f877528401f5826acfcd (patch)
tree49d643ef980f7bb790902bb409dc112fd2695ac2
parent33b7cc34c2d9ae536c9e1844a47b73f6e5d62671 (diff)
downloadguix-patches-issue-72101.tar
guix-patches-issue-72101.tar.gz
gnu: Add perl-minimumversion.issue-72101
* gnu/packages/perl.scm (perl-minimumversion): New variable. Change-Id: I731567f257d8415b4cf834ab22c7e64699a8b28f
-rw-r--r--gnu/packages/perl.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fe75ffa4c4..bbc06d320c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6877,6 +6877,46 @@ from various sources. For instance, it contains all IANA types and the
knowledge of Apache.")
(license (package-license perl))))
+(define-public perl-minimumversion
+ (package
+ (name "perl-minimumversion")
+ (version "1.40")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DB/DBOOK/Perl-MinimumVersion-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "145yl4qv14xcrr74w1qvdb6s0h5lj8smnfawfnj0rmv0rdwab2bm"))))
+ (build-system perl-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-programs
+ (lambda _
+ (wrap-program (string-append #$output "/bin/perlver")
+ (list "PERL5LIB" ":"
+ 'prefix
+ (list (string-append (getenv "PERL5LIB") ":"
+ #$output
+ "/lib/perl5/site_perl")))))))))
+ (inputs (list bash-minimal))
+ (propagated-inputs (list perl-file-find-rule
+ perl-file-find-rule-perl
+ perl-params-util
+ perl-ppi
+ perl-ppix-regexp
+ perl-ppix-utils))
+ (home-page "https://metacpan.org/release/Perl-MinimumVersion")
+ (synopsis "Find a minimum required version of perl for Perl code")
+ (description
+ "@samp{Perl::MinimumVersion} takes Perl source code and calculates the
+minimum version of perl required to be able to run it. Because it is
+based on @samp{PPI}, it can do this without having to actually load
+the code. The distribution comes with a script called @samp{perlver}.")
+ (license license:perl-license)))
+
(define-public perl-mixin-linewise
(package
(name "perl-mixin-linewise")