summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Cirrottola <luca.cirrottola@inria.fr>2024-07-29 19:36:04 +0200
committerGuix Patches Tester <>2024-07-29 20:09:15 +0200
commit613d629cb4ae97144b8dc613e9e3a882a4762f46 (patch)
treeccb6312f28e628445fea317429e3481e386ecccd
parent677c822009bdaffaa51c2eb0131ab9d08fd59fd1 (diff)
downloadguix-patches-issue-72071.tar
guix-patches-issue-72071.tar.gz
Skip test_check_version since the patch-settings phase needs to modify the test reference file.issue-72071
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f17367e5eb..d6c35cb4bb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1728,7 +1728,12 @@ incompatible with HDF5.")
(substitute* "hl/fortran/src/Makefile.in"
(("libhdf5hl_fortran_la_LDFLAGS =")
(string-append "libhdf5hl_fortran_la_LDFLAGS = -Wl,-rpath="
- (assoc-ref outputs "fortran") "/lib")))))
+ (assoc-ref outputs "fortran") "/lib")))
+ ;; Skip test_check_version since the "patch-settings" phase
+ ;; will modify the test reference.
+ (substitute* "test/test_check_version.sh.in"
+ (("TESTING\\(\\).*" all)
+ (string-append all "\nSKIP; exit 0\n")))))
(add-after 'configure 'patch-settings
(lambda _
;; libhdf5.settings contains the full path of the