summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvgeny Pisemsky <mail@pisemsky.site>2024-07-10 18:00:06 +0300
committerGuix Patches Tester <>2024-07-10 18:20:51 +0200
commite0d466f8b2011f7af428425df2f3f8e569376312 (patch)
tree0ba2837406c2ca028b2af6fa0b526ac085e512b3
parent71694363f6cc79e44955acbd9f7ca108e658caca (diff)
downloadguix-patches-issue-72037.tar
guix-patches-issue-72037.tar.gz
gnu: Add python-svgelements.issue-72037
* gnu/packages/python-xyz.scm (python-svgelements): New variable. Change-Id: Ief5aa396d2073b1235f5bd742343e38a588bd086
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93eeab8ea9..49a9e98de4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -153,6 +153,7 @@
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2024 TakeV <takev@disroot.org>
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31735,6 +31736,26 @@ For the most part it's transliterated from C, the major differences are:
"Jinxed is an implementation of a subset of the Python curses library.")
(license license:mpl2.0)))
+(define-public python-svgelements
+ (package
+ (name "python-svgelements")
+ (version "1.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "svgelements" version))
+ (sha256
+ (base32 "1xrp7yxg65dqdrmghriljf9hh2smq2zhzr2hzmqifgfd0ijas0kw"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-scipy python-numpy python-pillow))
+ (home-page "https://github.com/meerk40t/svgelements")
+ (synopsis "SVG parsing for elements, paths, and other SVG objects")
+ (description
+ "This module does high fidelity SVG parsing and geometric rendering.
+The goal is to successfully and correctly process SVG for use with any
+scripts that may need or want to use SVG files as geometric data.")
+ (license license:expat)))
+
(define-public python-svgutils
(package
(name "python-svgutils")