summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-07-10 09:05:34 +0000
committerGuix Patches Tester <>2024-07-10 11:49:33 +0200
commit3e8fd131f63092685c0fed63598b5b904682e299 (patch)
tree2899c2368e79bf6a42a489ef183274f723eb7091
parent71694363f6cc79e44955acbd9f7ca108e658caca (diff)
downloadguix-patches-issue-72031.tar
guix-patches-issue-72031.tar.gz
gnu: ugrep: Update to 6.2.0.issue-72031
* gnu/packages/search.scm (ugrep): Update to 6.2.0. [source] linux binaries are not present anymore. [inputs] add dependency on brotli for brotli support. Change-Id: I81f14ab4792d7939bd5a8e5b1e9c2fbb954988ab
-rw-r--r--gnu/packages/search.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 75e3252f02..928068b774 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -737,22 +737,20 @@ bibliographic data and simple document and bibtex retrieval.")
(define-public ugrep
(package
(name "ugrep")
- (version "6.1.0")
+ (version "6.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Genivia/ugrep")
(commit (string-append "v" version))))
(sha256
- (base32 "01zgvwhawz1sv3sib31jgbs5q27yc4kqmhz3v9l1zbqkkhwxsvqy"))
+ (base32 "1j3cz6y1rqz64604afk7fa00yqmwjpgmnd7gsaa4x3kgldqfdlr2"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
#~(begin
(delete-file-recursively "bin/win32") ; pre-built
(delete-file-recursively "bin/win64") ; pre-built
- (delete-file-recursively "bin/linux_amd64") ; pre-built
- (delete-file-recursively "bin/linux_arm64") ; pre-built
(for-each (lambda (regexp)
(for-each delete-file
(find-files "tests" regexp)))
@@ -765,6 +763,7 @@ bibliographic data and simple document and bibtex retrieval.")
lzip ;; lzma
pcre2
zlib
+ brotli
`(,zstd "lib")))
(arguments
(list