summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-21 19:38:52 +0100
committerGuix Patches Tester <>2024-06-21 20:50:25 +0200
commit5c61a051c4f4137148663721086e4773a11a2e20 (patch)
treeb873214df4ba45bd9d3896523ff3f371969942fb
parentc77b76c9cf6757cacb8a0cb9ba03933ab55fb3fc (diff)
downloadguix-patches-issue-71702.tar
guix-patches-issue-71702.tar.gz
gnu: Add python-jwst-reffiles.issue-71702
* gnu/packages/astronomy.scm (python-jwst-reffiles): New variable. Change-Id: I6c8f80e0b26109c31c610d242a364db0ac9a66a5
-rw-r--r--gnu/packages/astronomy.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c6f69d2e03..2ce0d66894 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4225,6 +4225,47 @@ science corrections sequentially, producing both fully-calibrated individual
exposures and high-level data products (mosaics, extracted spectra, etc.).")
(license license:bsd-3)))
+(define-public python-jwst-reffiles
+ (package
+ (name "python-jwst-reffiles")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jwst_reffiles" version))
+ (sha256
+ (base32 "1dlw955cw49qczdmimglmlcbal8vd3wbv5j48ckllvjgd59pwr3s"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; FIXME: Invistigate why it failes on python-jwst side where the
+ ;; python-tweakwcs is built just fine:
+ ;;
+ ;; <...>/tweakwcs/matchutils.py:18: in <module>
+ ;; from stsci.stimage import xyxymatch
+ ;; E ModuleNotFoundError: No module named 'stsci.stimage'
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'sanity-check))))
+ (propagated-inputs
+ (list python-astropy
+ python-jwst
+ python-matplotlib
+ python-numpy
+ python-scipy))
+ (native-inputs
+ (list python-pytest
+ python-stsci-stimage))
+ (home-page "https://github.com/spacetelescope/jwst_reffiles")
+ (synopsis "Tool for JWST's CRDS-formatted reference files creation")
+ (description
+ "This package provides a tool to create @acronym{Calibration References
+Data System,CRDS}-formatted reference files for @acronym{James Webb Space
+Telescope,JWST} from a set of input dark current files and a set of flat field
+files.")
+ (license license:bsd-3)))
+
(define-public python-pyerfa
(package
(name "python-pyerfa")