summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Quandour <adam.quandour@gmail.com>2024-05-25 00:38:07 +0300
committerGuix Patches Tester <>2024-05-25 16:32:54 +0200
commit899eef546522942ff80ddd889bc645c805c28be6 (patch)
tree1ffd397fb9458498364f7087bf492e08394bac9a
parent016fd7720db06f0945e345cc9d5043642f3b8720 (diff)
downloadguix-patches-issue-71184.tar
guix-patches-issue-71184.tar.gz
gnu: Add ruby-appraisal.issue-71184
* gnu/packages/ruby.scm (ruby-appraisal): New variable.
-rw-r--r--gnu/packages/ruby.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5c1e666bb0..53b411ba8d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1495,6 +1495,33 @@ line of code.")
;; of the Expat license.
(license license:bsd-3)))
+(define-public ruby-appraisal
+ (package
+ (name "ruby-appraisal")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "appraisal" version))
+ (sha256
+ (base32
+ "1knkxrjagaqf418lkgd7xvfb5rh143d19ld8vfq16y8jpqhr561n"))))
+ (build-system ruby-build-system)
+ ;; tests need Internet access.
+ (arguments '(#:tests? #f))
+ (native-inputs
+ (list ruby-activesupport
+ ruby-rspec
+ ruby-thor-0.14.6))
+ (synopsis "A Ruby library for testing your library against different versions of dependencies")
+ (description "Appraisal integrates with bundler and rake to test
+your library against different versions of dependencies in repeatable
+scenarios called \"appraisals\". Appraisal is designed to make it
+easy to check for regressions in your library without interfering
+ with day-to-day development using Bundler.")
+ (home-page "https://github.com/thoughtbot/appraisal")
+ (license license:expat)))
+
(define-public ruby-awesome-print
(package
(name "ruby-awesome-print")
@@ -3383,6 +3410,29 @@ interfaces.")
(home-page "http://whatisthor.com/")
(license license:expat)))
+(define-public ruby-thor-0.14.6
+ ;; needed for ruby-appraisal
+ (package
+ (name "ruby-thor")
+ (version "0.14.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thor" version))
+ (sha256
+ (base32
+ "18qmgv38gfw9clhq6szyw5kcxkkk8xr7c0klp3pk3cyznzbapif7"))))
+ (build-system ruby-build-system)
+ ;; couldn't run tests
+ ;; "No Rakefile found"
+ (arguments `(#:tests? #f))
+ (native-inputs (list ruby-rspec ruby-simplecov ruby-webmock))
+ (synopsis "Ruby toolkit for building command-line interfaces")
+ (description "Thor is a toolkit for building powerful command-line
+interfaces.")
+ (home-page "http://whatisthor.com/")
+ (license license:expat)))
+
(define-public ruby-lumberjack
(package
(name "ruby-lumberjack")