summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Batista <nandre@riseup.net>2024-05-24 20:39:03 -0300
committerGuix Patches Tester <>2024-05-25 02:10:30 +0200
commit3d9851d9c627c76a5feacd14c5ea7d2cf89709b4 (patch)
tree0d7a57c20fefb2780c8ff25303cd3e86174d21dc
parent016fd7720db06f0945e345cc9d5043642f3b8720 (diff)
downloadguix-patches-issue-71181.tar
guix-patches-issue-71181.tar.gz
gnu: make-torbrowser: Fix fontconfig regex substitution.issue-71181
* gnu/packages/tor-browsers.scm (make-torbrowser): Update the regex string to match upstream changes which incidentaly fixes browser crashes when trying to save a local file. Revert commit 6489f97f4a999b9b5e9b1a16d51c905e0cde4cdf, since it is not needed anymore. User may need to remove their current '~/.torbrowser' directory. See: https://gitlab.torproject.org/tpo/applications/tor-browser-build/-/commit/f834378bd2e23a556c9a0ea289b45fdcff76b0cc https://github.com/NixOS/nixpkgs/issues/307095#issuecomment-2083208021 https://github.com/NixOS/nixpkgs/pull/307832/commits/c69a216eec2f8f3ae1ddbaf051666d7eff424440
-rw-r--r--gnu/packages/tor-browsers.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/tor-browsers.scm b/gnu/packages/tor-browsers.scm
index 0c43804881..c0e6315cba 100644
--- a/gnu/packages/tor-browsers.scm
+++ b/gnu/packages/tor-browsers.scm
@@ -739,7 +739,7 @@ Browser.")
(copy-recursively (in-vicinity #$assets "fontconfig")
(in-vicinity lib "fontconfig"))
(substitute* (in-vicinity lib "fontconfig/fonts.conf")
- (("<dir>fonts</dir>")
+ (("<dir prefix=\"cwd\">fonts</dir>")
(format #f "<dir>~a</dir>" (in-vicinity lib "fonts"))))
(delete-file-recursively (in-vicinity lib "fonts"))
(copy-recursively (in-vicinity #$assets "fonts")
@@ -805,11 +805,7 @@ Browser.")
"https://gnuzilla.gnu.org/mozzarella")
(format #t "pref(~s, ~s);~%"
"lightweightThemes.getMoreURL"
- "https://gnuzilla.gnu.org/mozzarella")
- ;; FIXME: https://github.com/NixOS/nixpkgs/issues/307095
- (format #t "pref(~s, ~a);~%"
- "widget.use-xdg-desktop-portal.file-picker"
- "1"))))))
+ "https://gnuzilla.gnu.org/mozzarella"))))))
(add-after 'autoconfig 'autoconfig-tor
(lambda* (#:key inputs #:allow-other-keys)
(let ((lib (in-vicinity #$output "lib/torbrowser"))