summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-05-24 12:31:46 +0800
committerGuix Patches Tester <>2024-05-24 07:18:58 +0200
commite67f8ea356afd367407938a5225d871e63cb2156 (patch)
tree3b3b8c4dbd0092d6a2ae1ae5f6523c19f42affae
parentba854e02c410521d1d668451ef32eed27be9e540 (diff)
downloadguix-patches-issue-71161.tar
guix-patches-issue-71161.tar.gz
gnu: obs: Update to 30.1.2.issue-71161
* gnu/packages/video.scm (obs): Update to 30.1.2. [arguments]: Add "-DENABLE_QSV11=OFF" to configure-flags. Add MESA to LD_LIBRARY_PATH for 'obs'. [inputs]: Add libdatachannel, qrcodegen-cpp and vulkan-headers. Replace ffmpeg-4 with ffmpeg, Qt 5 with Qt 6. Change-Id: Id74c52512eb18727b0c8c8a0a7ed4c892a5e76c2
-rw-r--r--gnu/packages/video.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2e7ba6d10e..3782198a17 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -109,6 +109,7 @@
#:use-module (guix build-system waf)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages audio)
@@ -3965,7 +3966,7 @@ be used for realtime video capture via Linux-specific APIs.")
(define-public obs
(package
(name "obs")
- (version "29.1.3")
+ (version "30.1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3975,7 +3976,7 @@ be used for realtime video capture via Linux-specific APIs.")
(file-name (git-file-name name version))
(sha256
(base32
- "192p7m3g8ynbkq3s894w6a0w6gix3k237q5jwqrrr8idwfwwyh0g"))
+ "02pm6397h7l0xhdpscbh1kq8y98zx236z95wvw60kbhq38s0i0ik"))
(patches
(search-patches "obs-modules-location.patch"))))
(build-system cmake-build-system)
@@ -3986,6 +3987,7 @@ be used for realtime video capture via Linux-specific APIs.")
"-DENABLE_UNIT_TESTS=ON"
"-DENABLE_NEW_MPEGTS_OUTPUT=OFF"
"-DENABLE_AJA=OFF"
+ "-DENABLE_QSV11=OFF"
;; Browser plugin requires cef, but it is not packaged yet.
;; <https://bitbucket.org/chromiumembedded/cef/src/master/>
"-DBUILD_BROWSER=OFF")
@@ -3998,6 +4000,9 @@ be used for realtime video capture via Linux-specific APIs.")
`("QT_PLUGIN_PATH" ":" prefix (,plugin-path))
`("LD_LIBRARY_PATH" ":" prefix
(,(string-append #$(this-package-input "vlc")
+ "/lib")
+ ;; TODO: Remove this once our mesa has glvnd support.
+ ,(string-append #$(this-package-input "mesa")
"/lib"))))))))))
(native-search-paths
(list (search-path-specification
@@ -4017,12 +4022,13 @@ be used for realtime video capture via Linux-specific APIs.")
bash-minimal
curl
eudev
- ffmpeg-4
+ ffmpeg
fontconfig
freetype
glib
jack-1
jansson
+ libdatachannel
libglvnd
libva
libx264
@@ -4036,12 +4042,13 @@ be used for realtime video capture via Linux-specific APIs.")
pipewire
pulseaudio
python
- qtbase-5
- qtsvg-5
- qtx11extras
- qtwayland-5
+ qrcodegen-cpp
+ qtbase
+ qtsvg
+ qtwayland
speexdsp
v4l-utils
+ vulkan-headers
vlc
wayland
wayland-protocols