summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-05-23 13:47:06 +0200
committerGuix Patches Tester <>2024-05-23 14:19:18 +0200
commit67efecd9baac376b46b41ad282dfa8fb50a9c3b3 (patch)
tree0e878b4381f36a379728454bda7f5c708fa02b26
parent7c85b817d9f32b3fed08477c6dcee733b6526f64 (diff)
downloadguix-patches-issue-71145.tar
guix-patches-issue-71145.tar.gz
gnu: ocaml-sedlex: Update to 3.2.issue-71145
* gnu/packages/haxe.scm (ocaml-sedlex): Update to 3.2. (ocaml-sedlex-2): New variable. (ocaml-piqilib) <propagated-inputs>: Replace ocaml-sedlex by ocaml-sedlex-2. * gnu/packages/ocaml.scm (haxe) <inputs>: Replace ocaml-sedlex by ocaml-sedlex-2. Change-Id: I0ae3609f8db22589d8fdd110d1b7b92f6fead15d
-rw-r--r--gnu/packages/haxe.scm2
-rw-r--r--gnu/packages/ocaml.scm28
2 files changed, 25 insertions, 5 deletions
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index c7af07325f..f1cdc8732f 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -177,7 +177,7 @@ interactive languages.")
ocaml-extlib
ocaml-luv
ocaml-ptmap
- ocaml-sedlex
+ ocaml-sedlex-2
ocaml-sha
ocaml-xml-light
pcre2
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 10b98ca758..c96b374a99 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3772,7 +3772,7 @@ and consumable.")
(define-public ocaml-sedlex
(package
(name "ocaml-sedlex")
- (version "2.6")
+ (version "3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3781,10 +3781,10 @@ and consumable.")
(file-name (git-file-name name version))
(sha256
(base32
- "1z8mmk1idh9hjhh2b9rp5b1h8kmzcxhagqkw0pvxn6ykx1brskq1"))))
+ "1vzsmp8mvx9vrgjr5chsk2p2s5ii08c9kizw9ilx78jj30nzamz5"))))
(build-system dune-build-system)
(arguments
- (list #:tests? #f ; no tests
+ (list ;#:tests? #f ; no tests
#:package "sedlex"
#:phases
#~(modify-phases %standard-phases
@@ -3807,6 +3807,7 @@ and consumable.")
(add-before 'build 'chmod
(lambda _
(for-each (lambda (file) (chmod file #o644)) (find-files "." ".*")))))))
+ (native-inputs (list ocaml-ppx-expect))
(propagated-inputs
(list ocaml-gen ocaml-ppxlib ocaml-uchar))
(inputs
@@ -3816,6 +3817,25 @@ and consumable.")
(description "Lexer generator for Unicode and OCaml.")
(license license:expat)))
+(define-public ocaml-sedlex-2
+ (package
+ (inherit ocaml-sedlex)
+ (name "ocaml-sedlex")
+ (version "2.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-community/sedlex")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z8mmk1idh9hjhh2b9rp5b1h8kmzcxhagqkw0pvxn6ykx1brskq1"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ocaml-sedlex)
+ ((#:tests? _ #t) #f))) ; no tests
+ (native-inputs '())))
+
(define-public ocaml-uchar
(package
(name "ocaml-uchar")
@@ -5218,7 +5238,7 @@ Format module of the OCaml standard library.")
(list which))
(propagated-inputs
`(("ocaml-xmlm" ,ocaml-xmlm)
- ("ocaml-sedlex" ,ocaml-sedlex)
+ ("ocaml-sedlex" ,ocaml-sedlex-2)
("ocaml-easy-format" ,ocaml-easy-format)
("ocaml-base64" ,ocaml-base64)))
(home-page "https://piqi.org")