summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-17 22:27:16 +0300
committerGuix Patches Tester <>2024-05-17 21:47:37 +0200
commitcb72b18b8b73afdcc2c3a946cc2a10e902b009fa (patch)
tree0a18547ad9f12cc99cbd4873d3e60980ca92a9e3
parentcf0f009133b36ae1f4bea172b4904f2fb03b333d (diff)
downloadguix-patches-issue-71014.tar
guix-patches-issue-71014.tar.gz
gnu: Add go-github-com-pion-ice-v2.issue-71014
* gnu/packages/golang-xyz.scm (go-github-com-pion-ice-v2): New variable. Change-Id: I06f3e26ef7aa5e1a71319c636b4f5846c0c2eb2a
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a8a6cd69d7..12ace7a6bc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3020,6 +3020,33 @@ on top of the standard library @code{flag} package.")
as a part of @url{https://github.com/pion, Pion} WebRTC implementation.")
(license license:expat)))
+(define-public go-github-com-pion-ice-v2
+ (package
+ (inherit go-github-com-pion-ice-v3)
+ (name "go-github-com-pion-ice")
+ (version "2.3.24")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/ice/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mh7l31vv15gxpl61f22jwpc77b5l9wx4hbjv4h8cgmpb9911cv8"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments
+ go-github-com-pion-ice-v3)
+ ((#:unpack-path flags ''())
+ "github.com/pion/ice/v2")
+ ((#:import-path flags ''())
+ "github.com/pion/ice/v2")))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs go-github-com-pion-ice-v3)
+ (replace "go-github-com-pion-mdns" go-github-com-pion-mdns-v0)
+ (replace "go-github-com-pion-stun-v2" go-github-com-pion-stun)
+ (replace "go-github-com-pion-turn" go-github-com-pion-turn-v2)))))
+
(define-public go-github-com-pion-logging
(package
(name "go-github-com-pion-logging")