summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergio Pastor PĂ©rez <sergio.pastorperez@outlook.es>2024-05-05 16:44:08 +0200
committerGuix Patches Tester <>2024-05-05 17:15:30 +0200
commit85814c7e945d9e6266f236f893dbdc642b4c90ea (patch)
tree6153a354ed87167e94fdf37f551d65883bac2d85
parentd277adfac68c010600d491e89a29b6922a21b4ef (diff)
downloadguix-patches-issue-70787.tar
guix-patches-issue-70787.tar.gz
gnu: Add heic-to-dynamic-gnome-wallpaper.issue-70787
* gnu/packages/rust-apps.scm (heic-to-dynamic-gnome-wallpaper): New variable. Change-Id: I74b87a11e7f77d6a40262c6298bdf9c95a9c9438
-rw-r--r--gnu/packages/rust-apps.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d73bd1a030..41d8c4efac 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -723,6 +723,40 @@ While it does not seek to mirror all of find's powerful functionality, it provid
defaults for 80% of the use cases.")
(license (list license:expat license:asl2.0))))
+(define-public heic-to-dynamic-gnome-wallpaper
+ (package
+ (name "heic-to-dynamic-gnome-wallpaper")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "heic-to-dynamic-gnome-wallpaper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0k94nxbyvxr1ls3myfn2k8in466wdlgd5f5kv7vyrb3dm298ycf8"))))
+ (build-system cargo-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libheif))
+ (arguments
+ `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-base64" ,rust-base64-0.13)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-clap" ,rust-clap-3)
+ ("rust-colored" ,rust-colored-2)
+ ("rust-indicatif" ,rust-indicatif-0.16)
+ ("rust-libheif-rs" ,rust-libheif-rs-0.15)
+ ("rust-plist" ,rust-plist-1)
+ ("rust-png" ,rust-png-0.17)
+ ("rust-quick-xml" ,rust-quick-xml-0.22)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/jwuensche/heic-to-dynamic-gnome-wallpaper")
+ (synopsis
+ "Convert MacOS's dynamic wallpapers to dynamic gnome xml wallpapers")
+ (description
+ "CLI tool to convert heic image containers used in
+@code{MacOS's} dynamic wallpapers to dynamic gnome xml wallpapers.")
+ (license license:gpl3)))
+
(define-public hexyl
(package
(name "hexyl")