summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Hallsby <karl@hallsby.com>2024-05-02 10:35:35 -0500
committerGuix Patches Tester <>2024-05-02 18:01:31 +0200
commit9afa848b2cb40f26e56e0166475329613deb9127 (patch)
tree6485d22241494580cc3d466af391c48d85d2b9fa
parent8bf41c80ef13ea57e834f4e23d649bd99a3e08fc (diff)
downloadguix-patches-issue-70719.tar
guix-patches-issue-70719.tar.gz
gnu: tla2tools: Add UseParallelGC to Java command in wrapper scriptsissue-70719
* gnu/pcakages/java.scm: Add -XX:+UseParallelGC to generated wrapper scripts for TLA+'s binary tools. TLA+'s tools request (and throw a warning message) when you invoke them without Java's parallel GC flag. Including this flag removes the warning message and should improve performance (theoretically). Change-Id: I12f7432db21db31ae2b0b30cc7f41f4a6af58b0a
-rw-r--r--gnu/packages/java.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a54c1d1d06..8947336cc2 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2024 Raven Hallsby <karl@hallsby.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -14447,7 +14448,7 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
(display
(string-append
"#!/bin/sh\n"
- java " -cp " java-cp " " class " \"$@\""))))
+ java " -XX:+UseParallelGC " " -cp " java-cp " " class " \"$@\""))))
(chmod file #o755)))))
;; bin/wrapper . java-class
'(("pcal" . "pcal.trans")