summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-04-26 09:10:06 +0200
committerGuix Patches Tester <>2024-04-26 09:33:50 +0200
commit2772c9ccece5877304ed6441f16858477a7b8ba7 (patch)
tree57aba0c3d1a0b00ca44f335b3009def5815976c4
parentd6780ad2cc76576d4d3cbd9b1e404568c8287355 (diff)
downloadguix-patches-issue-70585.tar
guix-patches-issue-70585.tar.gz
gnu: Add emacs-ellama.issue-70585
* gnu/packages/emacs-xyz.scm (emacs-ellama): New variable. Change-Id: I47bf40971adca845aa132d08f59cd083154bec0e
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5da3f28545..4dc05e82c0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4932,6 +4932,31 @@ environment set through Direnv.")
that the binary uses instead of the actual binary contents.")
(license license:gpl3+)))
+(define-public emacs-ellama
+ (package
+ (name "emacs-ellama")
+ (version "0.9.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/s-kostyaev/ellama")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "1nwwqvl91c65r45yxa2dcl4a41r3ahw6294h79riya48nrp8kn54"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-dash emacs-llm emacs-spinner))
+ (home-page "https://github.com/s-kostyaev/ellama")
+ (synopsis "Tool for interacting with LLMs")
+ (description
+ "Ellama is a tool for interacting with large language models from Emacs.
+It allows you to ask questions and receive responses from the LLMs. Ellama
+can perform various tasks such as translation, code review, summarization,
+enhancing grammar/spelling or wording and more through the Emacs interface.
+Ellama natively supports streaming output, making it effortless to use with
+your preferred text editor.")
+ (license license:gpl3+)))
+
(define-public emacs-org-fc
(package
(name "emacs-org-fc")