summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-05-01 12:40:02 +0200
committerGuix Patches Tester <>2024-05-01 13:14:38 +0200
commitaabc1a4e5cf36ee788e3260071f99310a57c44eb (patch)
tree273512acdc82776e36924a468cb4616b1c9c1f51
parentddf3759645ba76ef532658a257ae74fe0b1788b5 (diff)
downloadguix-patches-issue-70584.tar
guix-patches-issue-70584.tar.gz
gnu: Add emacs-llm.issue-70584
* gnu/packages/emacs-xyz.scm (emacs-llm): New variable. Change-Id: Ie89eac7a4f0a31245b6d826ae9885a7092528ced
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1ce56fd576..f9fb0e251d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1606,6 +1606,27 @@ on stdout instead of using a socket as the Emacsclient does.")
libgit2 bindings for Emacs, intended to boost the performance of Magit.")
(license license:gpl2+))))
+(define-public emacs-llm
+ (package
+ (name "emacs-llm")
+ (version "0.13.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ahyatt/llm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "1q7djz4zx1br4d3g46f1m5cbxwl050qjmsm2cy7zcww64rrkcj0l"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ahyatt/llm")
+ (synopsis "Emacs library abstracting Large Language Model capabilities.")
+ (description
+ "This package provides interfaces to abstract various @acronym{LLM, large
+language model}s out in the world. To respect user freedom, it will warn you
+before interacting with non-free LLMs.")
+ (license license:gpl3+)))
+
(define-public emacs-magit
;; Use this unreleased commit to benefit from a recent improvements with
;; regard to adding git trailers such as "Reviewed-by".