summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-04-27 18:54:53 +0200
committerGuix Patches Tester <>2024-04-27 19:33:21 +0200
commitc2767d50e4cc9417aa8efc1fed7b3b5e2a955a10 (patch)
treef908b68a560ba01c97885198e3757ed2cabdeaca
parentdb931c201f3e8630f2d63f221d4598a7cba1f861 (diff)
downloadguix-patches-issue-70570.tar
guix-patches-issue-70570.tar.gz
guix: pyproject-build-system: Ignore unwanted pytest flags.issue-70570
* guix/build/pyproject-build-system.scm : Ignore unwanted pytest flags. Change-Id: Ib9f1602e5af11227e5b7ce124f0f9be4fa2b78e4
-rw-r--r--guix/build/pyproject-build-system.scm91
1 files changed, 89 insertions, 2 deletions
diff --git a/guix/build/pyproject-build-system.scm b/guix/build/pyproject-build-system.scm
index c69ccc9d64..b9b66259d2 100644
--- a/guix/build/pyproject-build-system.scm
+++ b/guix/build/pyproject-build-system.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -135,7 +136,89 @@ builder.build_wheel(sys.argv[2], config_settings=config_settings)"
wheel-dir
config-settings)))
-(define* (check #:key tests? test-backend test-flags #:allow-other-keys)
+(define pytest-default-ignore-alist
+ '(("cov" . ("--cov" "--cov-reset" "--cov-report" "--cov-config"
+ "--no-cov-on-fail" "--no-cov" "--cov-fail-under"
+ "--cov-append" "--cov-branch" "--cov-context"))
+ ("mypy" . ("--mypy" "--mypy-config-file" "--mypy-ignore-missing-imports"))
+ ("isort" . ("--isort"))
+ ("flake8" . ("--flake8"))
+ ("black" . ("--black"))
+ ("flakes" . ("--flakes"))
+ ("pep8" . ("--pep8"))))
+
+(define (pytest-ignore-flags-plugin flags)
+ "This function converts an list of flags into a string that can
+ be instantiated as a python pytest plugin."
+ (format #f "\
+import pytest
+
+def pytest_addoption(parser):
+ group = parser.getgroup('guix','Guix ignored options')
+ options = [~{~s, ~}]
+ for option in options:
+ group.addoption(option, action='append', nargs='?')"
+ flags))
+
+(define (call-with-guix-pytest-plugin inputs thunk)
+ "This function emulates command line options provided by pytest plugins in
+the absence of the plugins defining these options.
+
+This is done by selecting absent plugins, gettings their flags defined in
+PYTEST-DEFAULT-IGNORE-ALIST, and generating the plugin from there with
+PYTEST-IGNORE-FLAGS-PLUGIN."
+ (let* ((former-path (getenv "PYTHONPATH"))
+ (input-names
+ (filter (match-lambda
+ (((name . _) ...)
+ (if (string-prefix? "python-pytest-" name)
+ name
+ #f))
+ ( _ #f))
+ inputs))
+ (filtered-flags
+ (filter identity
+ (append-map
+ (match-lambda
+ ((group . flags)
+ (if (member (string-append "python-pytest-" group)
+ input-names)
+ (list #f)
+ flags))
+ (_ (list #f)))
+ pytest-default-ignore-alist))))
+ (dynamic-wind
+ (lambda ()
+ (setenv "PYTHONPATH"
+ (string-append
+ (if former-path
+ (string-append former-path ":")
+ "")
+ ".guix-pytest"))
+ (setenv "PYTEST_PLUGINS"
+ (string-append
+ (if (getenv "PYTEST_PLUGINS")
+ (string-append former-path ",")
+ "")
+ "pytest_guix_plugin"))
+ (mkdir-p ".guix-pytest")
+ (with-output-to-file ".guix-pytest/__init__.py"
+ (lambda _ (display "")))
+ (with-output-to-file ".guix-pytest/pytest_guix_plugin.py"
+ (lambda _
+ (display (pytest-ignore-flags-plugin filtered-flags)))))
+ thunk
+ (lambda ()
+ (setenv "PYTHONPATH" former-path)
+ (unsetenv "PYTEST_PLUGINS")
+ (when (file-exists? ".guix-pytest")
+ (delete-file-recursively ".guix-pytest"))))))
+
+(define-syntax-rule (with-guix-pytest-plugin inputs exp ...)
+ "Evaluate EXP in a context where the Guix pytest plugin is added."
+ (call-with-guix-pytest-plugin inputs (lambda () exp ...)))
+
+(define* (check #:key inputs tests? test-backend test-flags #:allow-other-keys)
"Run the test suite of a given Python package."
(if tests?
;; Unfortunately with PEP 517 there is no common method to specify test
@@ -158,7 +241,8 @@ builder.build_wheel(sys.argv[2], config_settings=config_settings)"
(format #t "Using ~a~%" use-test-backend)
(match use-test-backend
('pytest
- (apply invoke pytest "-vv" test-flags))
+ (with-guix-pytest-plugin inputs
+ (apply invoke pytest "-vv" test-flags)))
('nose
(apply invoke nosetests "-v" test-flags))
('nose2
@@ -379,3 +463,6 @@ See https://reproducible-builds.org/specs/source-date-epoch/."
(apply python:python-build #:inputs inputs #:phases phases args))
;;; pyproject-build-system.scm ends here
+;;; Local Variables:
+;;; eval: (put 'with-guix-pytest-plugin 'scheme-indent-function 1)
+;;; End: