summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-04-25 02:22:35 -0700
committerGuix Patches Tester <>2024-04-25 12:18:53 +0200
commit4b6cf3fe4e3ba10dead2e938de7720ca76e6f10f (patch)
tree478fab4c64c28a5cf41c46e869a77a3c657f5a17
parent83e6437e92ad056838fe170963d920d446d0e4db (diff)
downloadguix-patches-issue-70563.tar
guix-patches-issue-70563.tar.gz
gnu: Add pkcs11-helper.issue-70563
* gnu/packages/security-token.scm (pkcs11-helper): New variable. Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
-rw-r--r--gnu/packages/security-token.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 00a7f97582..5e20424001 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -394,6 +394,30 @@ authentication, encryption and digital signatures. OpenSC implements the PKCS
#15 standard and the PKCS #11 API.")
(license license:lgpl2.1+)))
+
+(define-public pkcs11-helper
+ (package
+ (name "pkcs11-helper")
+ (version "1.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
+ version "/pkcs11-helper-" version ".tar.bz2"))
+ (sha256
+ (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
+ (build-system gnu-build-system)
+ (inputs (list openssl-1.1 pcsc-lite))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/OpenSC/pkcs11-helper")
+ (synopsis "Library that simplifies the interaction with PKCS#11 providers")
+ (description
+ "Pkcs11-helper is a library that simplifies the interaction with
+PKCS#11 providers for end-user applications")
+ (license (list license:gpl2 license:bsd-3))))
+
+
(define-public yubico-piv-tool
(package
(name "yubico-piv-tool")