summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-04-24 12:34:25 +0800
committerGuix Patches Tester <>2024-04-24 11:15:15 +0200
commit6c1c338bfcc784998931cbf44f0d5e5eef0ebfda (patch)
treefa7064676b553e426c3fb4c8075aa754c5829f2a
parent2d19e505f6f9f82aebc9ba8c74ba223818acd9bc (diff)
downloadguix-patches-issue-70546.tar
guix-patches-issue-70546.tar.gz
gnu: cairo: Fix cross-compilation.issue-70546
* gnu/packages/gtk.scm (cairo)[arguments]: Add ‘fix-cross-compilation’ phase when cross-compiling. Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
-rw-r--r--gnu/packages/gtk.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..678bc89378 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
@@ -182,7 +182,19 @@ such as mate-panel and xfce4-panel.")
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:glib-or-gtk? #t
#:configure-flags
- (list "-Dtests=disabled")))
+ (list "-Dtests=disabled")
+ ,@(if (%current-target-system)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compilation
+ (lambda _
+ ;; XXX: Let meson-build-system can customize the property
+ (substitute* "meson.build"
+ (("'ipc_rmid_deferred_release', 'auto'")
+ ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
+ ;; XXX: check it on hurd.
+ "'ipc_rmid_deferred_release', 'true'"))))))
+ '())))
(native-inputs
`(,@(if (target-hurd?)
'()