summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-04-23 15:32:09 +0200
committerGuix Patches Tester <>2024-04-23 15:49:11 +0200
commita8c9443b760ee52250937b825ddfaacd329cba90 (patch)
tree7f63919838da0a3ad4a76cbbff31deb23bcf0f47
parentd8dfbe83c23ede9294538bd5a966ab222eaabcc0 (diff)
downloadguix-patches-issue-70536.tar
guix-patches-issue-70536.tar.gz
gnu: Add r-seraster.issue-70536
* gnu/packages/bioconductor.scm (r-seraster): New variable. Change-Id: I345dcbdfba23b34f122d7c193604cf950fe0d8f0
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0fca094977..828d9cfe36 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11025,6 +11025,46 @@ sequence motif occurrences across a large set of sequences centred at a common
reference point and sorted by a user defined feature.")
(license license:gpl3+)))
+;; This is not a Bioconductor package but it depends on three packages.
+(define-public r-seraster
+ ;; There are no tags or releases.
+ (let ((commit "4fdc1ffe5d3feb65de9880329d221cf276b393a1")
+ (revision "1"))
+ (package
+ (name "r-seraster")
+ (version (git-version "0.99.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JEFworks-Lab/SEraster")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y33lk8q0h9nfzmf7slxxvw3l0djassp4l63nsjpm3p6z4pah5s4"))))
+ (properties `((upstream-name . "SEraster")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-ggplot2
+ r-matrix
+ r-rearrr
+ r-sf
+ r-spatialexperiment
+ r-summarizedexperiment))
+ (home-page "https://github.com/JEFworks-Lab/SEraster")
+ (synopsis
+ "Rasterization framework for scalable spatial omics data analysis")
+ (description "SEraster is a rasterization preprocessing framework that
+aggregates cellular information into spatial pixels to reduce resource requirements
+for spatial omics data analysis. This package reduces the number of points in
+spatial omics datasets for downstream analysis through a process of rasterization
+where single cells gene expression or cell-type labels are aggregated into equally
+sized pixels based on a user-defined resolution. SEraster can be incorporated
+with other packages to conduct downstream analyses for spatial omics datasets,
+such as detecting spatially variable genes.")
+ (license license:gpl3))))
+
(define-public r-sesame
(package
(name "r-sesame")